You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/utils/lua/patches/040-use-symbolic-functions....

12 lines
364 B
Diff

--- a/src/Makefile
+++ b/src/Makefile
@@ -56,7 +56,7 @@ $(LUA_A): $(CORE_O) $(LIB_O)
$(RANLIB) $@
$(LUA_SO): $(CORE_O) $(LIB_O)
- $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
+ $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
ln -fs $@.$(PKG_VERSION) $@
$(LUA_T): $(LUA_O) $(LUA_SO)