iproute2: update to 5.3.0

Update iproute2 to 5.3.0

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
master
DENG Qingfang 5 years ago committed by Hans Dedecker
parent 1fe1a200d9
commit eddbd68b6d

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2 PKG_NAME:=iproute2
PKG_VERSION:=5.2.0 PKG_VERSION:=5.3.0
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
PKG_HASH:=a5b95dec26353fc71dba9bb403e9343fad2a06bd69fb154a22a2aa2914f74da8 PKG_HASH:=cb1c1e45993a3bd2438543fd4332d70f1726a6e6ff97dc613a8258c993117b3f
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0 PKG_LICENSE:=GPL-2.0

@ -1,6 +1,6 @@
--- a/tc/Makefile --- a/tc/Makefile
+++ b/tc/Makefile +++ b/tc/Makefile
@@ -121,6 +121,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR @@ -123,6 +123,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
ifneq ($(IPT_LIB_DIR),) ifneq ($(IPT_LIB_DIR),)
CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\" CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
endif endif

@ -1,6 +1,6 @@
--- a/ip/Makefile --- a/ip/Makefile
+++ b/ip/Makefile +++ b/ip/Makefile
@@ -16,6 +16,13 @@ RTMONOBJ=rtmon.o @@ -17,6 +17,13 @@ RTMONOBJ=rtmon.o
include ../config.mk include ../config.mk
@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ) ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon TARGETS=ip rtmon
@@ -45,7 +52,7 @@ else @@ -46,7 +53,7 @@ else
ip: static-syms.o ip: static-syms.o
static-syms.o: static-syms.h static-syms.o: static-syms.h
@ -25,24 +25,24 @@
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \ sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
--- a/ip/ip.c --- a/ip/ip.c
+++ b/ip/ip.c +++ b/ip/ip.c
@@ -47,10 +47,16 @@ static void usage(void) @@ -48,10 +48,16 @@ static void usage(void)
fprintf(stderr, fprintf(stderr,
"Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n" "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
" ip [ -force ] -batch filename\n" " ip [ -force ] -batch filename\n"
+#ifndef IPROUTE2_TINY +#ifndef IPROUTE2_TINY
"where OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n" "where OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n"
" tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n" " tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n"
" netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n" " netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n"
" vrf | sr }\n" " vrf | sr | nexthop }\n"
+#else +#else
+"where OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n" + "where OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n"
+" mroute | mrule | monitor | netns | macsec | token | ila |\n" + " mroute | mrule | monitor | netns | macsec | token | ila |\n"
+" vrf | sr }\n" + " vrf | sr }\n"
+#endif +#endif
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n" " OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n" " -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
" -f[amily] { inet | inet6 | mpls | bridge | link } |\n" " -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
@@ -72,32 +78,44 @@ static const struct cmd { @@ -74,35 +80,49 @@ static const struct cmd {
int (*func)(int argc, char **argv); int (*func)(int argc, char **argv);
} cmds[] = { } cmds[] = {
{ "address", do_ipaddr }, { "address", do_ipaddr },
@ -86,7 +86,12 @@
+#endif +#endif
{ "vrf", do_ipvrf}, { "vrf", do_ipvrf},
{ "sr", do_seg6 }, { "sr", do_seg6 },
+#ifndef IPROUTE2_TINY
{ "nexthop", do_ipnh },
+#endif
{ "help", do_help }, { "help", do_help },
{ 0 }
};
--- a/lib/Makefile --- a/lib/Makefile
+++ b/lib/Makefile +++ b/lib/Makefile
@@ -3,6 +3,10 @@ include ../config.mk @@ -3,6 +3,10 @@ include ../config.mk

@ -1,6 +1,6 @@
--- a/tc/Makefile --- a/tc/Makefile
+++ b/tc/Makefile +++ b/tc/Makefile
@@ -108,7 +108,7 @@ LDLIBS += -L. -lm @@ -110,7 +110,7 @@ LDLIBS += -L. -lm
ifeq ($(SHARED_LIBS),y) ifeq ($(SHARED_LIBS),y)
LDLIBS += -ldl LDLIBS += -ldl
@ -9,7 +9,7 @@
endif endif
TCLIB := tc_core.o TCLIB := tc_core.o
@@ -138,7 +138,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc @@ -140,7 +140,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
all: tc $(TCSO) all: tc $(TCSO)
tc: $(TCOBJ) $(LIBNETLINK) libtc.a tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@ -18,7 +18,7 @@
libtc.a: $(TCLIB) libtc.a: $(TCLIB)
$(QUIET_AR)$(AR) rcs $@ $^ $(QUIET_AR)$(AR) rcs $@ $^
@@ -160,6 +160,7 @@ install: all @@ -162,6 +162,7 @@ install: all
clean: clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \ rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
rm -f emp_ematch.yacc.* rm -f emp_ematch.yacc.*
@ -26,7 +26,7 @@
q_atm.so: q_atm.c q_atm.so: q_atm.c
$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm $(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
@@ -199,4 +200,15 @@ static-syms.h: $(wildcard *.c) @@ -201,4 +202,15 @@ static-syms.h: $(wildcard *.c)
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \ sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
done > $@ done > $@

@ -11,7 +11,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
--- a/ip/rtm_map.c --- a/ip/rtm_map.c
+++ b/ip/rtm_map.c +++ b/ip/rtm_map.c
@@ -48,6 +48,8 @@ char *rtnl_rtntype_n2a(int id, char *buf @@ -54,6 +54,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
return "nat"; return "nat";
case RTN_XRESOLVE: case RTN_XRESOLVE:
return "xresolve"; return "xresolve";
@ -20,7 +20,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
default: default:
snprintf(buf, len, "%d", id); snprintf(buf, len, "%d", id);
return buf; return buf;
@@ -83,6 +85,8 @@ int rtnl_rtntype_a2n(int *id, char *arg) @@ -89,6 +91,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
res = RTN_UNICAST; res = RTN_UNICAST;
else if (strcmp(arg, "throw") == 0) else if (strcmp(arg, "throw") == 0)
res = RTN_THROW; res = RTN_THROW;
@ -31,7 +31,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
if (!end || end == arg || *end || res > 255) if (!end || end == arg || *end || res > 255)
--- a/include/uapi/linux/rtnetlink.h --- a/include/uapi/linux/rtnetlink.h
+++ b/include/uapi/linux/rtnetlink.h +++ b/include/uapi/linux/rtnetlink.h
@@ -228,6 +228,7 @@ enum { @@ -235,6 +235,7 @@ enum {
RTN_THROW, /* Not in this table */ RTN_THROW, /* Not in this table */
RTN_NAT, /* Translate this address */ RTN_NAT, /* Translate this address */
RTN_XRESOLVE, /* Use external resolver */ RTN_XRESOLVE, /* Use external resolver */

Loading…
Cancel
Save