refresh 2.6.35 patches

SVN-Revision: 23033
v19.07.3_mercusys_ac12_duma
Florian Fainelli 14 years ago
parent 9bb6f3b5f3
commit ed008fe1e8

@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c --- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -372,6 +372,8 @@ static struct cfi_fixup fixup_table[] = @@ -372,6 +372,8 @@ static struct cfi_fixup fixup_table[] =
static void cfi_fixup_major_minor(struct cfi_private *cfi, static void cfi_fixup_major_minor(struct cfi_private *cfi,
struct cfi_pri_amdstd *extp) struct cfi_pri_amdstd *extp)
{ {
@ -9,7 +9,7 @@
if (cfi->mfr == CFI_MFR_SAMSUNG && cfi->id == 0x257e && if (cfi->mfr == CFI_MFR_SAMSUNG && cfi->id == 0x257e &&
extp->MajorVersion == '0') extp->MajorVersion == '0')
extp->MajorVersion = '1'; extp->MajorVersion = '1';
@@ -404,6 +406,9 @@ struct mtd_info *cfi_cmdset_0002(struct @@ -404,6 +406,9 @@ struct mtd_info *cfi_cmdset_0002(struct
mtd->reboot_notifier.notifier_call = cfi_amdstd_reboot; mtd->reboot_notifier.notifier_call = cfi_amdstd_reboot;
@ -19,7 +19,7 @@
if (cfi->cfi_mode==CFI_MODE_CFI){ if (cfi->cfi_mode==CFI_MODE_CFI){
unsigned char bootloc; unsigned char bootloc;
__u16 adr = primary?cfi->cfiq->P_ADR:cfi->cfiq->A_ADR; __u16 adr = primary?cfi->cfiq->P_ADR:cfi->cfiq->A_ADR;
@@ -417,16 +422,24 @@ struct mtd_info *cfi_cmdset_0002(struct @@ -417,16 +422,24 @@ struct mtd_info *cfi_cmdset_0002(struct
*/ */
cfi_fixup_major_minor(cfi, extp); cfi_fixup_major_minor(cfi, extp);

@ -176,7 +176,7 @@
unsigned int vced_count, vcei_count; unsigned int vced_count, vcei_count;
@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file @@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
/* /*
* For the first processor also print the system type * For the first processor also print the system type
*/ */

@ -554,7 +554,7 @@
#include <asm/uaccess.h> #include <asm/uaccess.h>
@@ -826,6 +827,13 @@ static int mtd_ioctl(struct file *file, @@ -826,6 +827,13 @@ static int mtd_ioctl(struct file *file,
file->f_pos = 0; file->f_pos = 0;
break; break;
} }

@ -15,7 +15,7 @@
void *priv; void *priv;
--- a/drivers/mtd/nand/plat_nand.c --- a/drivers/mtd/nand/plat_nand.c
+++ b/drivers/mtd/nand/plat_nand.c +++ b/drivers/mtd/nand/plat_nand.c
@@ -91,7 +91,18 @@ static int __devinit plat_nand_probe(str @@ -96,7 +96,18 @@ static int __devinit plat_nand_probe(str
} }
/* Scan to find existance of the device */ /* Scan to find existance of the device */

@ -71,7 +71,7 @@
depends on NETFILTER_ADVANCED depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile --- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile +++ b/net/netfilter/Makefile
@@ -91,6 +91,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT) @@ -91,6 +91,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o

@ -132,10 +132,11 @@
e = (struct ipt_entry *)(loc_cpu_entry + off); e = (struct ipt_entry *)(loc_cpu_entry + off);
if (copy_to_user(userptr + off if (copy_to_user(userptr + off
@@ -980,6 +1021,14 @@ copy_entries_to_user(unsigned int total_ @@ -979,6 +1020,14 @@ copy_entries_to_user(unsigned int total_
ret = -EFAULT;
goto free_counters; goto free_counters;
} }
+
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH; + flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
+ if (copy_to_user(userptr + off + if (copy_to_user(userptr + off
+ + offsetof(struct ipt_entry, ip.flags), + + offsetof(struct ipt_entry, ip.flags),
@ -143,7 +144,6 @@
+ ret = -EFAULT; + ret = -EFAULT;
+ goto free_counters; + goto free_counters;
+ } + }
+
for (i = sizeof(struct ipt_entry); for (i = sizeof(struct ipt_entry);
i < e->target_offset; i < e->target_offset;
i += m->u.match_size) {

@ -1,6 +1,6 @@
--- a/arch/mips/include/asm/string.h --- a/arch/mips/include/asm/string.h
+++ b/arch/mips/include/asm/string.h +++ b/arch/mips/include/asm/string.h
@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__ @@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
#define __HAVE_ARCH_MEMSET #define __HAVE_ARCH_MEMSET
extern void *memset(void *__s, int __c, size_t __count); extern void *memset(void *__s, int __c, size_t __count);

@ -1,6 +1,6 @@
--- a/include/linux/slab.h --- a/include/linux/slab.h
+++ b/include/linux/slab.h +++ b/include/linux/slab.h
@@ -130,8 +130,8 @@ int kmem_ptr_validate(struct kmem_cache @@ -130,8 +130,8 @@ int kmem_ptr_validate(struct kmem_cache
* to do various tricks to work around compiler limitations in order to * to do various tricks to work around compiler limitations in order to
* ensure proper constant folding. * ensure proper constant folding.
*/ */

@ -61,7 +61,7 @@
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd); extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
@@ -501,6 +505,29 @@ static inline void double_unlock(struct @@ -501,6 +505,29 @@ static inline void double_unlock(struct
#endif /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */ #endif /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
#endif /* __KERNEL__ */ #endif /* __KERNEL__ */
@ -127,7 +127,7 @@
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */ #endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
--- a/fs/mini_fo/aux.c --- a/fs/mini_fo/aux.c
+++ b/fs/mini_fo/aux.c +++ b/fs/mini_fo/aux.c
@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb, @@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd); err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
/* validate */ /* validate */

@ -1,6 +1,6 @@
--- a/fs/mini_fo/super.c --- a/fs/mini_fo/super.c
+++ b/fs/mini_fo/super.c +++ b/fs/mini_fo/super.c
@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int @@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */ #endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */

@ -20,7 +20,7 @@
#else #else
static inline int kobject_uevent(struct kobject *kobj, static inline int kobject_uevent(struct kobject *kobj,
enum kobject_action action) enum kobject_action action)
@@ -262,6 +268,16 @@ static inline int add_uevent_var(struct @@ -262,6 +268,16 @@ static inline int add_uevent_var(struct
static inline int kobject_action_type(const char *buf, size_t count, static inline int kobject_action_type(const char *buf, size_t count,
enum kobject_action *type) enum kobject_action *type)
{ return -EINVAL; } { return -EINVAL; }

@ -11,7 +11,7 @@
endif # NEW_LEDS endif # NEW_LEDS
--- a/drivers/leds/Makefile --- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile +++ b/drivers/leds/Makefile
@@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += @@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o

@ -14,7 +14,7 @@
endif # NEW_LEDS endif # NEW_LEDS
--- a/drivers/leds/Makefile --- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile +++ b/drivers/leds/Makefile
@@ -49,3 +49,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += @@ -49,3 +49,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o

@ -601,7 +601,7 @@
dev->checkpointBlockList[i] = -1; dev->checkpointBlockList[i] = -1;
} }
@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device @@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev) static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
{ {
@ -926,7 +926,7 @@
{ {
unsigned char cDelta; /* column parity delta */ unsigned char cDelta; /* column parity delta */
unsigned lDelta; /* line parity delta */ unsigned lDelta; /* line parity delta */
@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char @@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
return 0; /* no error */ return 0; /* no error */
if (lDelta == ~lDeltaPrime && if (lDelta == ~lDeltaPrime &&
@ -936,7 +936,7 @@
/* Single bit (recoverable) error in data */ /* Single bit (recoverable) error in data */
bit = 0; bit = 0;
@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char @@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
if (cDelta & 0x02) if (cDelta & 0x02)
bit |= 0x01; bit |= 0x01;
@ -945,7 +945,7 @@
return -1; return -1;
data[lDelta] ^= (1 << bit); data[lDelta] ^= (1 << bit);
@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char @@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
} }
if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) + if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
@ -954,7 +954,7 @@
/* Reccoverable error in ecc */ /* Reccoverable error in ecc */
*read_ecc = *test_ecc; *read_ecc = *test_ecc;
@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char @@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
/* Unrecoverable error */ /* Unrecoverable error */
return -1; return -1;
@ -1398,7 +1398,7 @@
{ {
unsigned char *alias; unsigned char *alias;
int ret; int ret;
@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry @@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
return ret; return ret;
} }
@ -1560,7 +1560,7 @@
static int yaffs_file_flush(struct file *file, fl_owner_t id) static int yaffs_file_flush(struct file *file, fl_owner_t id)
#else #else
static int yaffs_file_flush(struct file *file) static int yaffs_file_flush(struct file *file)
@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file @@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
yaffs_Device *dev = obj->myDev; yaffs_Device *dev = obj->myDev;
T(YAFFS_TRACE_OS, T(YAFFS_TRACE_OS,
@ -1571,7 +1571,7 @@
yaffs_GrossLock(dev); yaffs_GrossLock(dev);
@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct @@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
yaffs_Device *dev; yaffs_Device *dev;
@ -1591,7 +1591,7 @@
BUG_ON(!PageLocked(pg)); BUG_ON(!PageLocked(pg));
#else #else
if (!PageLocked(pg)) if (!PageLocked(pg))
@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct @@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
yaffs_GrossLock(dev); yaffs_GrossLock(dev);
@ -1604,7 +1604,7 @@
yaffs_GrossUnlock(dev); yaffs_GrossUnlock(dev);
@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct @@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
flush_dcache_page(pg); flush_dcache_page(pg);
kunmap(pg); kunmap(pg);
@ -3193,7 +3193,7 @@
if (n < step) { if (n < step) {
n++; n++;
continue; continue;
@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file @@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
char *end; char *end;
char *mask_name; char *mask_name;
const char *x; const char *x;
@ -3202,7 +3202,7 @@
int i; int i;
int done = 0; int done = 0;
int add, len = 0; int add, len = 0;
@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file @@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
while (!done && (pos < count)) { while (!done && (pos < count)) {
done = 1; done = 1;
@ -3213,7 +3213,7 @@
switch (buf[pos]) { switch (buf[pos]) {
case '+': case '+':
@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file @@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
mask_name = NULL; mask_name = NULL;
mask_bitfield = simple_strtoul(buf + pos, &end, 0); mask_bitfield = simple_strtoul(buf + pos, &end, 0);
@ -3240,7 +3240,7 @@
mask_name = mask_flags[i].mask_name; mask_name = mask_flags[i].mask_name;
mask_bitfield = mask_flags[i].mask_bitfield; mask_bitfield = mask_flags[i].mask_bitfield;
done = 0; done = 0;
@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file @@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
if (mask_name != NULL) { if (mask_name != NULL) {
done = 0; done = 0;
@ -3249,7 +3249,7 @@
case '-': case '-':
rg &= ~mask_bitfield; rg &= ~mask_bitfield;
break; break;
@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file @@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS; yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
@ -5691,7 +5691,7 @@
{ {
/* Get the real object in case we were fed a hard link as an equivalent object */ /* Get the real object in case we were fed a hard link as an equivalent object */
equivalentObject = yaffs_GetEquivalentObject(equivalentObject); equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object * @@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
} }
@ -7622,7 +7622,7 @@
int nToCopy; int nToCopy;
int n = nBytes; int n = nBytes;
int nDone = 0; int nDone = 0;
@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object @@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
dev = in->myDev; dev = in->myDev;
while (n > 0) { while (n > 0) {
@ -7657,7 +7657,7 @@
if (dev->nShortOpCaches > 0) { if (dev->nShortOpCaches > 0) {
/* If we can't find the data in the cache, then load it up. */ /* If we can't find the data in the cache, then load it up. */
@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object @@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
cache->locked = 1; cache->locked = 1;
@ -7673,7 +7673,7 @@
cache->locked = 0; cache->locked = 0;
} else { } else {
/* Read into the local buffer then copy..*/ /* Read into the local buffer then copy..*/
@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object @@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
yaffs_GetTempBuffer(dev, __LINE__); yaffs_GetTempBuffer(dev, __LINE__);
yaffs_ReadChunkDataFromObject(in, chunk, yaffs_ReadChunkDataFromObject(in, chunk,
localBuffer); localBuffer);
@ -7718,7 +7718,7 @@
} }
n -= nToCopy; n -= nToCopy;
@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object @@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
return nDone; return nDone;
} }
@ -7923,7 +7923,7 @@
int newFullChunks; int newFullChunks;
yaffs_Device *dev = in->myDev; yaffs_Device *dev = in->myDev;
@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in, @@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
yaffs_CheckGarbageCollection(dev); yaffs_CheckGarbageCollection(dev);
@ -7941,7 +7941,7 @@
if (newSize < oldFileSize) { if (newSize < oldFileSize) {
@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in, @@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
} }
@ -7968,7 +7968,7 @@
{ {
obj = yaffs_GetEquivalentObject(obj); obj = yaffs_GetEquivalentObject(obj);
@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object * @@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
@ -9789,7 +9789,7 @@
{ {
int init_failed = 0; int init_failed = 0;
unsigned x; unsigned x;
@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->chunkOffset = 0; dev->chunkOffset = 0;
dev->nFreeChunks = 0; dev->nFreeChunks = 0;
@ -9798,7 +9798,7 @@
if (dev->startBlock == 0) { if (dev->startBlock == 0) {
dev->internalStartBlock = dev->startBlock + 1; dev->internalStartBlock = dev->startBlock + 1;
dev->internalEndBlock = dev->endBlock + 1; dev->internalEndBlock = dev->endBlock + 1;
@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
/* Check geometry parameters. */ /* Check geometry parameters. */
@ -9823,7 +9823,7 @@
return YAFFS_FAIL; return YAFFS_FAIL;
} }
@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
return YAFFS_FAIL; return YAFFS_FAIL;
} }
@ -9836,7 +9836,7 @@
/* Got the right mix of functions? */ /* Got the right mix of functions? */
if (!yaffs_CheckDevFunctions(dev)) { if (!yaffs_CheckDevFunctions(dev)) {
/* Function missing */ /* Function missing */
@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->isMounted = 1; dev->isMounted = 1;
@ -9875,7 +9875,7 @@
/* /*
* Calculate chunkGroupBits. * Calculate chunkGroupBits.
@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
bits = ShiftsGE(x); bits = ShiftsGE(x);
/* Set up tnode width if wide tnodes are enabled. */ /* Set up tnode width if wide tnodes are enabled. */
@ -9896,7 +9896,7 @@
dev->tnodeWidth = 16; dev->tnodeWidth = 16;
dev->tnodeMask = (1<<dev->tnodeWidth)-1; dev->tnodeMask = (1<<dev->tnodeWidth)-1;
@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */ dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
/* Initialise temporary buffers and caches. */ /* Initialise temporary buffers and caches. */
@ -9905,7 +9905,7 @@
init_failed = 1; init_failed = 1;
dev->srCache = NULL; dev->srCache = NULL;
@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
if (!init_failed && if (!init_failed &&
dev->nShortOpCaches > 0) { dev->nShortOpCaches > 0) {
int i; int i;
@ -9940,7 +9940,7 @@
init_failed = 1; init_failed = 1;
dev->srLastUse = 0; dev->srLastUse = 0;
@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->cacheHits = 0; dev->cacheHits = 0;
@ -9979,7 +9979,7 @@
T(YAFFS_TRACE_ALWAYS, T(YAFFS_TRACE_ALWAYS,
(TSTR("yaffs: restored from checkpoint" TENDSTR))); (TSTR("yaffs: restored from checkpoint" TENDSTR)));
} else { } else {
@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->nBackgroundDeletions = 0; dev->nBackgroundDeletions = 0;
dev->oldestDirtySequence = 0; dev->oldestDirtySequence = 0;
@ -10011,7 +10011,7 @@
/* Clean up the mess */ /* Clean up the mess */
T(YAFFS_TRACE_TRACING, T(YAFFS_TRACE_TRACING,
(TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR))); (TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device * @@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
} }
@ -10710,7 +10710,7 @@
{ {
if (etags) { if (etags) {
memset(etags, 0, sizeof(*etags)); memset(etags, 0, sizeof(*etags));
@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags * @@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
* Returns YAFFS_OK or YAFFS_FAIL. * Returns YAFFS_OK or YAFFS_FAIL.
*/ */
int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev, int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
@ -11038,14 +11038,14 @@
+ yaffs_UnpackTags2(tags, &pt); + yaffs_UnpackTags2(tags, &pt);
+ } + }
+ } + }
+
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+ if (localData) + if (localData)
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__); + yaffs_ReleaseTempBuffer(dev, data, __LINE__);
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR) + if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED; tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
-
if (retval == 0) if (retval == 0)
return YAFFS_OK; return YAFFS_OK;
else else

@ -1,6 +1,6 @@
--- a/drivers/net/wireless/hostap/hostap_ap.c --- a/drivers/net/wireless/hostap/hostap_ap.c
+++ b/drivers/net/wireless/hostap/hostap_ap.c +++ b/drivers/net/wireless/hostap/hostap_ap.c
@@ -2336,13 +2336,13 @@ int prism2_ap_get_sta_qual(local_info_t @@ -2336,13 +2336,13 @@ int prism2_ap_get_sta_qual(local_info_t
addr[count].sa_family = ARPHRD_ETHER; addr[count].sa_family = ARPHRD_ETHER;
memcpy(addr[count].sa_data, sta->addr, ETH_ALEN); memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
if (sta->last_rx_silence == 0) if (sta->last_rx_silence == 0)

@ -8,7 +8,7 @@
#include <linux/ioport.h> #include <linux/ioport.h>
#include <linux/pci.h> #include <linux/pci.h>
@@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[] @@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[]
MODULE_DEVICE_TABLE(pci, divil_pci); MODULE_DEVICE_TABLE(pci, divil_pci);
static struct cdev cs5535_gpio_cdev; static struct cdev cs5535_gpio_cdev;

@ -24,7 +24,7 @@
* All of these routines try to estimate how many bits of randomness a * All of these routines try to estimate how many bits of randomness a
* particular randomness source. They do this by keeping track of the * particular randomness source. They do this by keeping track of the
* first and second order deltas of the event timings. * first and second order deltas of the event timings.
@@ -715,6 +725,61 @@ void add_disk_randomness(struct gendisk @@ -715,6 +725,61 @@ void add_disk_randomness(struct gendisk
} }
#endif #endif

@ -376,7 +376,7 @@
u32 pmucap; u32 pmucap;
if (!(cc->capabilities & SSB_CHIPCO_CAP_PMU)) if (!(cc->capabilities & SSB_CHIPCO_CAP_PMU))
@@ -516,15 +516,12 @@ void ssb_pmu_init(struct ssb_chipcommon @@ -516,15 +516,12 @@ void ssb_pmu_init(struct ssb_chipcommon
ssb_dprintk(KERN_DEBUG PFX "Found rev %u PMU (capabilities 0x%08X)\n", ssb_dprintk(KERN_DEBUG PFX "Found rev %u PMU (capabilities 0x%08X)\n",
cc->pmu.rev, pmucap); cc->pmu.rev, pmucap);

@ -76,7 +76,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -4261,6 +4261,7 @@ int can_nice(const struct task_struct *p @@ -4269,6 +4269,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) || return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }

@ -1,6 +1,6 @@
--- a/scripts/Makefile.lib --- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib +++ b/scripts/Makefile.lib
@@ -238,7 +238,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) @@ -238,7 +238,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@ quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \ cmd_lzma = (cat $(filter-out FORCE,$^) | \

Loading…
Cancel
Save