tcpdump: update to 4.9.3

Fixed CVEs:
	CVE-2017-16808
	CVE-2018-10103
	CVE-2018-10105
	CVE-2018-14461
	CVE-2018-14462
	CVE-2018-14463
	CVE-2018-14464
	CVE-2018-14465
	CVE-2018-14466
	CVE-2018-14467
	CVE-2018-14468
	CVE-2018-14469
	CVE-2018-14470
	CVE-2018-14879
	CVE-2018-14880
	CVE-2018-14881
	CVE-2018-14882
	CVE-2018-16227
	CVE-2018-16228
	CVE-2018-16229
	CVE-2018-16230
	CVE-2018-16300
	CVE-2018-16301
	CVE-2018-16451
	CVE-2018-16452
	CVE-2019-15166
	CVE-2019-15167

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
(cherry picked from commit 394273c066)
v19.07.3_mercusys_ac12_duma
DENG Qingfang 5 years ago committed by Hauke Mehrtens
parent 8e78bbb7bb
commit e5ab602c69

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tcpdump
PKG_VERSION:=4.9.2
PKG_VERSION:=4.9.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
http://www.tcpdump.org/release/
PKG_HASH:=798b3536a29832ce0cbb07fafb1ce5097c95e308a6f592d14052e1ef1505fe79
PKG_HASH:=2cd47cb3d460b6ff75f4a9940f594317ad456cfbf2bd2c8e5151e16559db6410
PKG_BUILD_PARALLEL:=1

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -6259,97 +6259,6 @@ $as_echo "no" >&6; }
@@ -6183,97 +6183,6 @@ $as_echo "no" >&6; }
fi
fi

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -5471,37 +5471,6 @@ $as_echo "Using $pfopen" >&6; }
@@ -5395,37 +5395,6 @@ $as_echo "Using $pfopen" >&6; }
LIBS="$LIBS $pfopen"
fi
fi
@ -38,7 +38,7 @@
#
# Look for pcap-config.
@@ -5657,51 +5626,6 @@ if test "x$ac_cv_lib_pcap_main" = xyes;
@@ -5581,51 +5550,6 @@ if test "x$ac_cv_lib_pcap_main" = xyes;
libpcap="-lpcap"
fi

@ -111,7 +111,7 @@
const char *
dnaddr_string(netdissect_options *ndo, u_short dnaddr)
{
@@ -1233,6 +1236,7 @@ dnaddr_string(netdissect_options *ndo, u
@@ -1230,6 +1233,7 @@ dnaddr_string(netdissect_options *ndo, u
return(tp->name);
}
@ -605,7 +605,7 @@
/*
--- a/print-sll.c
+++ b/print-sll.c
@@ -238,12 +238,14 @@ recurse:
@@ -249,12 +249,14 @@ recurse:
*/
switch (ether_type) {
@ -683,7 +683,7 @@
else if (IS_SRC_OR_DST_PORT(FTP_PORT)) {
ND_PRINT((ndo, ": "));
ftp_print(ndo, bp, length);
@@ -719,6 +730,7 @@ tcp_print(netdissect_options *ndo,
@@ -725,6 +736,7 @@ tcp_print(netdissect_options *ndo,
* XXX packet could be unaligned, it can go strange
*/
ns_print(ndo, bp + 2, length - 2, 0);
@ -691,7 +691,7 @@
} else if (IS_SRC_OR_DST_PORT(MSDP_PORT)) {
msdp_print(ndo, bp, length);
} else if (IS_SRC_OR_DST_PORT(RPKI_RTR_PORT)) {
@@ -726,6 +738,7 @@ tcp_print(netdissect_options *ndo,
@@ -732,6 +744,7 @@ tcp_print(netdissect_options *ndo,
}
else if (length > 0 && (IS_SRC_OR_DST_PORT(LDP_PORT))) {
ldp_print(ndo, bp, length);

Loading…
Cancel
Save