linux: update 3.1 to 3.1.4

SVN-Revision: 29470
v19.07.3_mercusys_ac12_duma
Jonas Gorski 13 years ago
parent 6e2ae90f4a
commit e33bb9ec66

@ -32,8 +32,8 @@ endif
ifeq ($(LINUX_VERSION),3.0.12)
LINUX_KERNEL_MD5SUM:=aa5d56ddc2ef01a61759ceeb0f6b8308
endif
ifeq ($(LINUX_VERSION),3.1.1)
LINUX_KERNEL_MD5SUM:=4db653798a325f759b8cf49a1b5e6011
ifeq ($(LINUX_VERSION),3.1.4)
LINUX_KERNEL_MD5SUM:=52643e5a013d450ad69627c3cac490cb
endif
# disable the md5sum check for unknown kernel versions

@ -10,7 +10,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{
u16 cmd;
@@ -883,3 +885,5 @@ static void __devinit quirk_usb_early_ha
@@ -882,3 +884,5 @@ static void __devinit quirk_usb_early_ha
quirk_usb_handoff_xhci(pdev);
}
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);

@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
FEATURES:=squashfs jffs2
DEFAULT_SUBTARGET:=danube
LINUX_VERSION:=3.1.3
LINUX_VERSION:=3.1.4
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves

@ -69,7 +69,7 @@ Subject: [PATCH 18/24] MIPS: lantiq: adds dwc_otg
obj-$(CONFIG_USB_WDM) += class/
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -2885,11 +2885,11 @@ hub_port_init (struct usb_hub *hub, stru
@@ -2891,11 +2891,11 @@ hub_port_init (struct usb_hub *hub, stru
udev->ttport = hdev->ttport;
} else if (udev->speed != USB_SPEED_HIGH
&& hdev->speed == USB_SPEED_HIGH) {

@ -1,7 +1,5 @@
Index: linux-3.1.1/arch/mips/lantiq/devices.c
===================================================================
--- linux-3.1.1.orig/arch/mips/lantiq/devices.c 2011-11-14 20:22:33.588135463 +0100
+++ linux-3.1.1/arch/mips/lantiq/devices.c 2011-11-14 20:22:34.328135495 +0100
--- a/arch/mips/lantiq/devices.c
+++ b/arch/mips/lantiq/devices.c
@@ -18,6 +18,7 @@
#include <linux/time.h>
#include <linux/io.h>
@ -10,7 +8,7 @@ Index: linux-3.1.1/arch/mips/lantiq/devices.c
#include <asm/bootinfo.h>
#include <asm/irq.h>
@@ -100,3 +101,20 @@
@@ -100,3 +101,20 @@ void __init ltq_register_pci(struct ltq_
pr_err("kernel is compiled without PCI support\n");
}
#endif
@ -31,21 +29,17 @@ Index: linux-3.1.1/arch/mips/lantiq/devices.c
+ cp1_base =
+ (void*)CPHYSADDR(dma_alloc_coherent(NULL, CP1_SIZE, &dma, GFP_ATOMIC));
+}
Index: linux-3.1.1/arch/mips/lantiq/devices.h
===================================================================
--- linux-3.1.1.orig/arch/mips/lantiq/devices.h 2011-11-14 20:22:33.588135463 +0100
+++ linux-3.1.1/arch/mips/lantiq/devices.h 2011-11-14 20:22:34.328135495 +0100
@@ -23,5 +23,6 @@
--- a/arch/mips/lantiq/devices.h
+++ b/arch/mips/lantiq/devices.h
@@ -23,5 +23,6 @@ extern void ltq_register_nor(struct phys
extern void ltq_register_wdt(void);
extern void ltq_register_asc(int port);
extern void ltq_register_pci(struct ltq_pci_data *data);
+extern void ltq_register_tapi(void);
#endif
Index: linux-3.1.1/arch/mips/lantiq/xway/Makefile
===================================================================
--- linux-3.1.1.orig/arch/mips/lantiq/xway/Makefile 2011-11-14 20:22:34.304135491 +0100
+++ linux-3.1.1/arch/mips/lantiq/xway/Makefile 2011-11-14 20:39:51.404179655 +0100
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
@@ -1,5 +1,7 @@
obj-y := sysctrl.o reset.o gpio.o gpio_stp.o gpio_ebu.o devices.o dma.o nand.o timer.o
@ -54,10 +48,8 @@ Index: linux-3.1.1/arch/mips/lantiq/xway/Makefile
obj-$(CONFIG_SOC_XWAY) += clk-xway.o prom-xway.o
obj-$(CONFIG_SOC_AMAZON_SE) += clk-ase.o prom-ase.o
obj-$(CONFIG_SOC_VR9) += clk-vr9.o prom-vr9.o
Index: linux-3.1.1/arch/mips/lantiq/xway/devices.c
===================================================================
--- linux-3.1.1.orig/arch/mips/lantiq/xway/devices.c 2011-11-14 20:22:34.092135483 +0100
+++ linux-3.1.1/arch/mips/lantiq/xway/devices.c 2011-11-14 20:22:34.328135495 +0100
--- a/arch/mips/lantiq/xway/devices.c
+++ b/arch/mips/lantiq/xway/devices.c
@@ -19,6 +19,7 @@
#include <linux/time.h>
#include <linux/io.h>
@ -66,7 +58,7 @@ Index: linux-3.1.1/arch/mips/lantiq/xway/devices.c
#include <asm/bootinfo.h>
#include <asm/irq.h>
@@ -99,3 +100,98 @@
@@ -99,3 +100,98 @@ ltq_register_etop(struct ltq_eth_data *e
platform_device_register(&ltq_etop);
}
}
@ -165,10 +157,8 @@ Index: linux-3.1.1/arch/mips/lantiq/xway/devices.c
+ ltq_spi.dev.platform_data = pdata;
+ platform_device_register(&ltq_spi);
+}
Index: linux-3.1.1/arch/mips/lantiq/xway/devices.h
===================================================================
--- linux-3.1.1.orig/arch/mips/lantiq/xway/devices.h 2011-11-11 21:19:27.000000000 +0100
+++ linux-3.1.1/arch/mips/lantiq/xway/devices.h 2011-11-14 20:22:34.328135495 +0100
--- a/arch/mips/lantiq/xway/devices.h
+++ b/arch/mips/lantiq/xway/devices.h
@@ -11,10 +11,17 @@
#include "../devices.h"
@ -187,10 +177,8 @@ Index: linux-3.1.1/arch/mips/lantiq/xway/devices.h
+extern void ltq_register_gpio_buttons(struct gpio_button *buttons, int cnt);
#endif
Index: linux-3.1.1/arch/mips/lantiq/Makefile
===================================================================
--- linux-3.1.1.orig/arch/mips/lantiq/Makefile 2011-11-14 20:22:33.640135462 +0100
+++ linux-3.1.1/arch/mips/lantiq/Makefile 2011-11-14 20:39:09.852178049 +0100
--- a/arch/mips/lantiq/Makefile
+++ b/arch/mips/lantiq/Makefile
@@ -4,7 +4,7 @@
# under the terms of the GNU General Public License version 2 as published
# by the Free Software Foundation.

@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
MAINTAINER:=Michael Buesch <m@bues.ch>
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
LINUX_VERSION:=3.1.3
LINUX_VERSION:=3.1.4
define Target/Description
TI OMAP-24xx

@ -1,7 +1,5 @@
Index: linux-3.1.1/drivers/cbus/retu.c
===================================================================
--- linux-3.1.1.orig/drivers/cbus/retu.c 2011-11-17 23:23:53.542699149 +0100
+++ linux-3.1.1/drivers/cbus/retu.c 2011-11-17 23:23:55.830689859 +0100
--- a/drivers/cbus/retu.c
+++ b/drivers/cbus/retu.c
@@ -53,9 +53,6 @@ struct retu {
int irq;
@ -70,10 +68,8 @@ Index: linux-3.1.1/drivers/cbus/retu.c
irq_set_nested_thread(irq, 1);
retu_irq_setup(irq);
}
Index: linux-3.1.1/drivers/cbus/tahvo.c
===================================================================
--- linux-3.1.1.orig/drivers/cbus/tahvo.c 2011-11-17 23:23:54.358695836 +0100
+++ linux-3.1.1/drivers/cbus/tahvo.c 2011-11-17 23:23:55.830689859 +0100
--- a/drivers/cbus/tahvo.c
+++ b/drivers/cbus/tahvo.c
@@ -48,11 +48,9 @@ struct tahvo {
int irq_end;
int irq;

@ -1,7 +1,5 @@
Index: linux-3.1.1/drivers/cbus/retu.c
===================================================================
--- linux-3.1.1.orig/drivers/cbus/retu.c 2011-11-17 23:09:26.498214061 +0100
+++ linux-3.1.1/drivers/cbus/retu.c 2011-11-17 23:15:50.280659655 +0100
--- a/drivers/cbus/retu.c
+++ b/drivers/cbus/retu.c
@@ -451,7 +451,8 @@ static int __devinit retu_probe(struct p
(rev >> 4) & 0x07, rev & 0x0f);
@ -12,10 +10,8 @@ Index: linux-3.1.1/drivers/cbus/retu.c
ret = request_threaded_irq(retu->irq, NULL, retu_irq_handler,
IRQF_ONESHOT, "retu", retu);
Index: linux-3.1.1/drivers/cbus/tahvo.c
===================================================================
--- linux-3.1.1.orig/drivers/cbus/tahvo.c 2011-11-17 23:15:46.684674232 +0100
+++ linux-3.1.1/drivers/cbus/tahvo.c 2011-11-17 23:15:50.280659655 +0100
--- a/drivers/cbus/tahvo.c
+++ b/drivers/cbus/tahvo.c
@@ -346,7 +346,8 @@ static int __devinit tahvo_probe(struct
(rev >> 4) & 0x0f, rev & 0x0f);

@ -1,7 +1,5 @@
Index: linux-3.1.1/drivers/video/omap/omapfb_main.c
===================================================================
--- linux-3.1.1.orig/drivers/video/omap/omapfb_main.c 2011-11-11 21:19:27.000000000 +0100
+++ linux-3.1.1/drivers/video/omap/omapfb_main.c 2011-11-16 23:10:16.554325659 +0100
--- a/drivers/video/omap/omapfb_main.c
+++ b/drivers/video/omap/omapfb_main.c
@@ -419,10 +419,10 @@ static void set_fb_fix(struct fb_info *f
fbi->screen_base = rg->vaddr;
@ -28,10 +26,8 @@ Index: linux-3.1.1/drivers/video/omap/omapfb_main.c
}
}
}
Index: linux-3.1.1/drivers/video/fbmem.c
===================================================================
--- linux-3.1.1.orig/drivers/video/fbmem.c 2011-11-11 21:19:27.000000000 +0100
+++ linux-3.1.1/drivers/video/fbmem.c 2011-11-16 23:20:56.055698968 +0100
--- a/drivers/video/fbmem.c
+++ b/drivers/video/fbmem.c
@@ -1369,8 +1369,10 @@ fb_mmap(struct file *file, struct vm_are
}

@ -1881,7 +1881,7 @@
#endif /* __DRIVERS_CBUS_CBUS_H */
--- a/drivers/cbus/retu.c
+++ b/drivers/cbus/retu.c
@@ -417,6 +417,11 @@ static int retu_allocate_children(struct
@@ -399,6 +399,11 @@ static int retu_allocate_children(struct
if (!child)
return -ENOMEM;
@ -1895,7 +1895,7 @@
--- a/drivers/cbus/tahvo.c
+++ b/drivers/cbus/tahvo.c
@@ -131,6 +131,7 @@ void tahvo_set_clear_reg_bits(struct dev
@@ -129,6 +129,7 @@ void tahvo_set_clear_reg_bits(struct dev
__tahvo_write_reg(tahvo, reg, w);
mutex_unlock(&tahvo->mutex);
}
@ -1903,7 +1903,7 @@
static irqreturn_t tahvo_irq_handler(int irq, void *_tahvo)
{
@@ -307,6 +308,11 @@ static int tahvo_allocate_children(struc
@@ -292,6 +293,11 @@ static int tahvo_allocate_children(struc
if (!child)
return -ENOMEM;

Loading…
Cancel
Save