uboot-envtools: Add TARGET_LDFLAGS to fix PIE and RELRO

Forward the OpenWrt TARGET_LDFLAGS to the linker of the fw_printenv tool.
In addition also use the more standard make invocation script.
With this change the fw_printenv tool is built with PIE and Full RELRO
support when activated globally in OpenWrt.

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
master
Hauke Mehrtens 5 years ago committed by Hauke Mehrtens
parent 39035df71c
commit b7b2be0b26

@ -51,16 +51,11 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/include/generated/autoconf.h touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
endef endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include MAKE_FLAGS += \
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
define Build/Compile TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
$(MAKE) -C $(PKG_BUILD_DIR) \ no-dot-config-targets=envtools \
CROSS_COMPILE="$(TARGET_CROSS)" \ envtools
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
HOSTLDFLAGS= \
no-dot-config-targets=envtools \
envtools
endef
define Package/uboot-envtools/conffiles define Package/uboot-envtools/conffiles
/etc/config/ubootenv /etc/config/ubootenv

@ -1,12 +1,15 @@
--- a/tools/env/Makefile --- a/tools/env/Makefile
+++ b/tools/env/Makefile +++ b/tools/env/Makefile
@@ -8,6 +8,10 @@ @@ -8,6 +8,13 @@
# with "CC" here for the maximum code reuse of scripts/Makefile.host. # with "CC" here for the maximum code reuse of scripts/Makefile.host.
override HOSTCC = $(CC) override HOSTCC = $(CC)
+ifneq ($(TARGET_CFLAGS),) +ifneq ($(TARGET_CFLAGS),)
+HOSTCFLAGS = $(TARGET_CFLAGS) +HOSTCFLAGS = $(TARGET_CFLAGS)
+endif +endif
+ifneq ($(TARGET_LDFLAGS),)
+HOSTLDFLAGS = $(TARGET_LDFLAGS)
+endif
+ +
# Compile for a hosted environment on the target # Compile for a hosted environment on the target
HOST_EXTRACFLAGS = -I$(srctree)/tools \ HOST_EXTRACFLAGS = -I$(srctree)/tools \

Loading…
Cancel
Save