resync patches for 2.6.30-rc3

SVN-Revision: 15494
v19.07.3_mercusys_ac12_duma
Imre Kaloz 15 years ago
parent fab598b675
commit a528df4bb6

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -561,6 +561,9 @@ endif @@ -566,6 +566,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include) NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS) CHECKFLAGS += $(NOSTDINC_FLAGS)

@ -609,7 +609,7 @@
select CRC32 select CRC32
--- a/drivers/net/Makefile --- a/drivers/net/Makefile
+++ b/drivers/net/Makefile +++ b/drivers/net/Makefile
@@ -151,6 +151,7 @@ obj-$(CONFIG_SLHC) += slhc.o @@ -152,6 +152,7 @@ obj-$(CONFIG_SLHC) += slhc.o
obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
obj-$(CONFIG_DUMMY) += dummy.o obj-$(CONFIG_DUMMY) += dummy.o

@ -1,8 +1,8 @@
--- a/drivers/input/misc/Kconfig --- a/drivers/input/misc/Kconfig
+++ b/drivers/input/misc/Kconfig +++ b/drivers/input/misc/Kconfig
@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU @@ -250,4 +250,20 @@ config INPUT_RB532_BUTTON
Say Y to include support for delivering PMU events via input To compile this driver as a module, choose M here: the
layer on NXP PCF50633. module will be called rb532_button.
+config INPUT_GPIO_BUTTONS +config INPUT_GPIO_BUTTONS
+ tristate "Polled GPIO buttons interface" + tristate "Polled GPIO buttons interface"
@ -23,8 +23,8 @@
endif endif
--- a/drivers/input/misc/Makefile --- a/drivers/input/misc/Makefile
+++ b/drivers/input/misc/Makefile +++ b/drivers/input/misc/Makefile
@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o @@ -24,3 +24,4 @@ obj-$(CONFIG_INPUT_SPARCSPKR) += sparcs
obj-$(CONFIG_INPUT_APANEL) += apanel.o obj-$(CONFIG_INPUT_UINPUT) += uinput.o
obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o obj-$(CONFIG_INPUT_YEALINK) += yealink.o
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o +obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o

@ -73,7 +73,7 @@
idx = phy_find_valid(idx, phydev->supported); idx = phy_find_valid(idx, phydev->supported);
--- a/include/linux/phy.h --- a/include/linux/phy.h
+++ b/include/linux/phy.h +++ b/include/linux/phy.h
@@ -477,6 +477,7 @@ void phy_start_machine(struct phy_device @@ -483,6 +483,7 @@ void phy_start_machine(struct phy_device
void phy_stop_machine(struct phy_device *phydev); void phy_stop_machine(struct phy_device *phydev);
int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd); int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd); int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);

@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -84,6 +84,10 @@ config IP175C_PHY @@ -96,6 +96,10 @@ config ADM6996_PHY
tristate "Driver for IC+ IP175C/IP178C switches" config MVSWITCH_PHY
select SWCONFIG tristate "Driver for Marvell 88E6060 switches"
+config AR8216_PHY +config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches" + tristate "Driver for Atheros AR8216 switches"
@ -16,8 +16,8 @@
@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o @@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
obj-$(CONFIG_ADM6996_PHY) += adm6996.o obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o

@ -1,6 +1,6 @@
--- a/init/main.c --- a/init/main.c
+++ b/init/main.c +++ b/init/main.c
@@ -807,7 +807,7 @@ static noinline int init_post(void) @@ -812,7 +812,7 @@ static noinline int init_post(void)
numa_default_policy(); numa_default_policy();
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0) if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)

@ -824,9 +824,9 @@
+be done automatically. +be done automatically.
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -1997,6 +1997,11 @@ L: linux-media@vger.kernel.org @@ -2490,6 +2490,11 @@ T: git git://git.kernel.org/pub/scm/linu
T: git kernel.org:/pub/scm/linux/kernel/git/mchehab/linux-2.6.git
S: Maintained S: Maintained
F: drivers/media/video/gspca/
+GPIOMMC DRIVER +GPIOMMC DRIVER
+P: Michael Buesch +P: Michael Buesch

@ -1,6 +1,6 @@
--- a/mm/shmem.c --- a/mm/shmem.c
+++ b/mm/shmem.c +++ b/mm/shmem.c
@@ -2587,6 +2587,16 @@ int shmem_unuse(swp_entry_t entry, struc @@ -2602,6 +2602,16 @@ int shmem_unuse(swp_entry_t entry, struc
/* common code */ /* common code */
@ -17,7 +17,7 @@
/** /**
* shmem_file_setup - get an unlinked file living in tmpfs * shmem_file_setup - get an unlinked file living in tmpfs
* @name: name for dentry (to be seen in /proc/<pid>/maps * @name: name for dentry (to be seen in /proc/<pid>/maps
@@ -2665,11 +2675,7 @@ int shmem_zero_setup(struct vm_area_stru @@ -2680,11 +2690,7 @@ int shmem_zero_setup(struct vm_area_stru
if (IS_ERR(file)) if (IS_ERR(file))
return PTR_ERR(file); return PTR_ERR(file);
@ -70,7 +70,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -5600,6 +5600,7 @@ int can_nice(const struct task_struct *p @@ -5665,6 +5665,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur || return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }

Loading…
Cancel
Save