patch to allow iproute2 to be cross compiled. could be a sed hack if we wanted/needed.

SVN-Revision: 57
v19.07.3_mercusys_ac12_duma
Ned Ludd 20 years ago
parent 6591d4013f
commit 75caa7e1f0

@ -0,0 +1,28 @@
diff -Nrup iproute2.orig/lib/Makefile iproute2/lib/Makefile
--- iproute2.orig/lib/Makefile 2000-04-16 13:42:52.000000000 -0400
+++ iproute2/lib/Makefile 2004-06-03 19:17:51.000000000 -0400
@@ -6,10 +6,10 @@ NLOBJ=ll_map.o libnetlink.o
all: libnetlink.a libutil.a
libnetlink.a: $(NLOBJ)
- ar rcs $@ $(NLOBJ)
+ $(AR) rcs $@ $(NLOBJ)
libutil.a: $(UTILOBJ) $(ADDLIB)
- ar rcs $@ $(UTILOBJ) $(ADDLIB)
+ $(AR) rcs $@ $(UTILOBJ) $(ADDLIB)
clean:
rm -f $(NLOBJ) $(UTILOBJ) $(ADDLIB) libnetlink.a libutil.a
diff -Nrup iproute2.orig/tc/Makefile iproute2/tc/Makefile
--- iproute2.orig/tc/Makefile 2000-04-16 13:42:53.000000000 -0400
+++ iproute2/tc/Makefile 2004-06-03 19:18:08.000000000 -0400
@@ -43,7 +43,7 @@ all: libtc.a tc
tc: $(TCOBJ) $(LIBNETLINK) $(LIBUTIL) $(TCLIB)
libtc.a: $(TCLIB)
- ar rcs $@ $(TCLIB)
+ $(AR) rcs $@ $(TCLIB)
clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc
Loading…
Cancel
Save