cleanup files using checkpatch.pl

SVN-Revision: 27162
v19.07.3_mercusys_ac12_duma
Florian Fainelli 13 years ago
parent d3b8685cd7
commit 6a5112a750

@ -23,7 +23,9 @@
void __init prom_putchar(char ch)
{
while ((UART_READ(UART_REG_FLAG) & UART_FLAG_TXFE) == 0);
while ((UART_READ(UART_REG_FLAG) & UART_FLAG_TXFE) == 0)
;
UART_WRITE(UART_REG_DATA, ch);
while ((UART_READ(UART_REG_FLAG) & UART_FLAG_TXFE) == 0);
while ((UART_READ(UART_REG_FLAG) & UART_FLAG_TXFE) == 0)
;
}

@ -16,10 +16,10 @@
#include <linux/interrupt.h>
#include <linux/ioport.h>
#include <linux/io.h>
#include <linux/bitops.h>
#include <asm/irq_cpu.h>
#include <asm/mipsregs.h>
#include <asm/bitops.h>
#include <asm/mach-adm5120/adm5120_defs.h>
@ -170,7 +170,8 @@ static void __init adm5120_intc_irq_init(void)
setup_irq(ADM5120_IRQ_INTC, &adm5120_intc_irq_action);
}
void __init arch_init_irq(void) {
void __init arch_init_irq(void)
{
mips_cpu_irq_init();
adm5120_intc_irq_init();
}

@ -249,7 +249,7 @@ static void __init prom_init_cmdline(void)
}
#else
static void inline prom_init_cmdline(void) {}
static inline void prom_init_cmdline(void) {}
#endif /* CONFIG_IMAGE_CMDLINE_HACK */
void __init prom_init(void)

@ -20,10 +20,12 @@
#include <linux/init.h>
#include <linux/kernel.h>
#include <linux/io.h>
#include <linux/reboot.h>
#include <linux/time.h>
#include <asm/bootinfo.h>
#include <asm/reboot.h>
#include <asm/time.h>
#include <asm/bootinfo.h>
#include <asm/mips_machine.h>
#include <asm/mach-adm5120/adm5120_info.h>

@ -103,7 +103,7 @@ static void __init eb214a_setup(void)
adm5120_add_device_gpio(EB214A_GPIO_DEV_MASK);
adm5120_add_device_uart(0);
//adm5120_add_device_uart(1);
/* adm5120_add_device_uart(1); */
adm5120_add_device_switch(5, eb214a_vlans);
@ -117,7 +117,7 @@ static void __init eb214a_setup(void)
adm5120_pci_set_irq_map(ARRAY_SIZE(eb214a_pci_irqs),
eb214a_pci_irqs);
// adm5120_add_device_usb();
/* adm5120_add_device_usb(); */
}
MIPS_MACHINE(MACH_ADM5120_EB_214A, "EB-214A", "Generic EB-214A", eb214a_setup);

@ -21,12 +21,12 @@
#include <linux/init.h>
#include <linux/spinlock.h>
#include <linux/io.h>
#include <linux/delay.h>
#include <linux/pci.h>
#include <linux/pci_ids.h>
#include <linux/pci_regs.h>
#include <asm/delay.h>
#include <asm/bootinfo.h>
#include <asm/mach-adm5120/adm5120_defs.h>
@ -71,8 +71,8 @@ static inline u32 read_cfgdata(void)
static inline u32 mkaddr(struct pci_bus *bus, unsigned int devfn, int where)
{
return (((bus->number & 0xFF) << 16) | ((devfn & 0xFF) << 8) | \
(where & 0xFC));
return ((bus->number & 0xFF) << 16) | ((devfn & 0xFF) << 8) | \
(where & 0xFC);
}
/* -------------------------------------------------------------------------*/

@ -89,7 +89,7 @@ static struct flash_desc flash_descs[2] = {
}
};
static const char *probe_types[] = {
static const char const *probe_types[] = {
"cfi_probe",
"jedec_probe",
"map_rom",
@ -97,7 +97,7 @@ static const char *probe_types[] = {
};
#ifdef CONFIG_MTD_PARTITIONS
static const char *parse_types[] = {
static const char const *parse_types[] = {
"cmdlinepart",
#ifdef CONFIG_MTD_REDBOOT_PARTS
"RedBoot",

@ -28,7 +28,7 @@
#define TRX_NO_HEADER 0x1 /* do not write TRX header */
#define TRX_GZ_FILES 0x2 /* contains individual gzip files */
#define TRX_MAX_OFFSET 3
#define TRX_MIN_KERNEL_SIZE 256*1024
#define TRX_MIN_KERNEL_SIZE (256 * 1024)
struct trx_header {
u32 magic; /* "HDR0" */

@ -64,7 +64,7 @@
#define TX_RING_SIZE 32
#define TX_QUEUE_LEN 28 /* Limit ring entries actually used. */
#define TX_TIMEOUT HZ*400
#define TX_TIMEOUT (HZ * 400)
#define RX_DESCS_SIZE (RX_RING_SIZE * sizeof(struct dma_desc *))
#define RX_SKBS_SIZE (RX_RING_SIZE * sizeof(struct sk_buff *))
@ -553,13 +553,11 @@ static irqreturn_t adm5120_switch_irq(int irq, void *dev_id)
#else
sw_int_ack(status);
if (status & (SWITCH_INT_RLD | SWITCH_INT_LDF)) {
if (status & (SWITCH_INT_RLD | SWITCH_INT_LDF))
adm5120_switch_rx(RX_RING_SIZE);
}
if (status & SWITCH_INT_SLD) {
if (status & SWITCH_INT_SLD)
adm5120_switch_tx();
}
#endif
return IRQ_HANDLED;
@ -721,7 +719,8 @@ static void adm5120_write_mac(struct net_device *dev)
sw_write_reg(SWITCH_REG_MAC_WT0, t);
while (!(sw_read_reg(SWITCH_REG_MAC_WT0) & MAC_WT0_MWD));
while (!(sw_read_reg(SWITCH_REG_MAC_WT0) & MAC_WT0_MWD))
;
}
static void adm5120_set_vlan(char *matrix)
@ -736,7 +735,8 @@ static void adm5120_set_vlan(char *matrix)
/* Now set/update the port vs. device lookup table */
for (port = 0; port < SWITCH_NUM_PORTS; port++) {
for (vlan_port=0; vlan_port<SWITCH_NUM_PORTS && !(matrix[vlan_port] & (0x00000001 << port)); vlan_port++);
for (vlan_port = 0; vlan_port < SWITCH_NUM_PORTS && !(matrix[vlan_port] & (0x00000001 << port)); vlan_port++)
;
if (vlan_port < SWITCH_NUM_PORTS)
adm5120_port[port] = adm5120_devs[vlan_port];
else

@ -11,8 +11,8 @@
#define _INCLUDE_ADM5120SW_H_
#define SIOCSMATRIX SIOCDEVPRIVATE
#define SIOCGMATRIX SIOCDEVPRIVATE+1
#define SIOCGADMINFO SIOCDEVPRIVATE+2
#define SIOCGMATRIX (SIOCDEVPRIVATE + 1)
#define SIOCGADMINFO (SIOCDEVPRIVATE + 2)
struct adm5120_sw_info {
u16 magic;

@ -114,8 +114,8 @@ urb_print(struct admhcd *ahcd, struct urb *urb, char *str, int small, int status
if (usb_pipecontrol(pipe)) {
admhc_dbg(ahcd, "setup(8):");
for (i = 0; i < 8 ; i++)
printk (" %02x", ((__u8 *) urb->setup_packet) [i]);
printk ("\n");
printk(KERN_INFO" %02x", ((__u8 *)urb->setup_packet)[i]);
printk(KERN_INFO "\n");
}
if (urb->transfer_buffer_length > 0 && urb->transfer_buffer) {
admhc_dbg(ahcd, "data(%d/%d):",
@ -124,8 +124,8 @@ urb_print(struct admhcd *ahcd, struct urb *urb, char *str, int small, int status
len = usb_pipeout(pipe) ?
urb->transfer_buffer_length : urb->actual_length;
for (i = 0; i < 16 && i < len; i++)
printk(" %02x", ((__u8 *)urb->transfer_buffer)[i]);
printk("%s stat:%d\n", i < len? "...": "", status);
printk(KERN_INFO " %02x", ((__u8 *)urb->transfer_buffer)[i]);
printk(KERN_INFO "%s stat:%d\n", i < len ? "..." : "", status);
}
}
#endif /* ADMHC_VERBOSE_DEBUG */
@ -525,7 +525,8 @@ static ssize_t fill_periodic_buffer(struct debug_buffer *buf)
char *next;
unsigned i;
if (!(seen = kmalloc(DBG_SCHED_LIMIT * sizeof *seen, GFP_ATOMIC)))
seen = kmalloc(DBG_SCHED_LIMIT * sizeof(*seen), GFP_ATOMIC);
if (!seen)
return 0;
seen_count = 0;
@ -542,7 +543,8 @@ static ssize_t fill_periodic_buffer(struct debug_buffer *buf)
/* dump a snapshot of the periodic schedule (and load) */
spin_lock_irqsave(&ahcd->lock, flags);
for (i = 0; i < NUM_INTS; i++) {
if (!(ed = ahcd->periodic [i]))
ed = ahcd->periodic[i];
if (!ed)
continue;
temp = scnprintf(next, size, "%2d [%3d]:", i, ahcd->load[i]);

@ -36,8 +36,8 @@
#include <linux/dmapool.h>
#include <linux/reboot.h>
#include <linux/debugfs.h>
#include <linux/io.h>
#include <asm/io.h>
#include <asm/irq.h>
#include <asm/system.h>
#include <asm/unaligned.h>

@ -615,9 +615,8 @@ static int td_done(struct admhcd *ahcd, struct urb *urb, struct td *td)
/* count all non-empty packets except control SETUP packet */
if ((type != PIPE_CONTROL || td->index != 0) && tdDBP != 0) {
if ((type != PIPE_CONTROL || td->index != 0) && tdDBP != 0)
urb->actual_length += tdDBP - td->data_dma + bl;
}
if (cc != TD_CC_NOERROR && cc < TD_CC_HCD0)
admhc_vdbg(ahcd,
@ -719,11 +718,10 @@ rescan_all:
* frame counter wraps and EDs with partially retired TDs
*/
if (likely(HC_IS_RUNNING(admhcd_to_hcd(ahcd)->state))) {
if (tick_before (tick, ed->tick)) {
if (tick_before(tick, ed->tick))
skip_ed:
last = &ed->ed_rm_next;
continue;
}
#if 0
if (!list_empty(&ed->td_list)) {
struct td *td;

@ -430,7 +430,7 @@ struct admhcd {
#define OHCI_QUIRK_BE_DESC 0x08 /* BE descriptors */
#define OHCI_QUIRK_BE_MMIO 0x10 /* BE registers */
#define OHCI_QUIRK_ZFMICRO 0x20 /* Compaq ZFMicro chipset*/
// there are also chip quirks/bugs in init logic
/* there are also chip quirks/bugs in init logic */
#ifdef DEBUG
struct dentry *debug_dir;

@ -32,8 +32,8 @@
#define NAME "adm5120_wdt"
#define VERSION "0.1"
static int expect_close = 0;
static int access = 0;
static int expect_close;
static int access;
static unsigned int timeout = DEFAULT_TIMEOUT;
static int nowayout = WATCHDOG_NOWAYOUT;
@ -71,9 +71,8 @@ static int wdt_open(struct inode *inode, struct file *file)
if (access)
return -EBUSY;
if (nowayout) {
if (nowayout)
__module_get(THIS_MODULE);
}
/* Activate timer */
wdt_reset_counter();
@ -93,9 +92,9 @@ static int wdt_release(struct inode *inode, struct file *file)
wdt_disable();
printk(KERN_INFO NAME ": disabling watchdog timer\n");
module_put(THIS_MODULE);
} else {
} else
printk(KERN_CRIT NAME ": device closed unexpectedly. WDT will not stop!\n");
}
access = 0;
return 0;
}
@ -163,19 +162,19 @@ static int wdt_ioctl(struct inode *inode, struct file *file,
}
}
static struct file_operations wdt_fops = {
owner: THIS_MODULE,
llseek: no_llseek,
write: wdt_write,
ioctl: wdt_ioctl,
open: wdt_open,
release: wdt_release,
static const struct file_operations wdt_fops = {
.owner = THIS_MODULE,
.llseek = no_llseek,
.write = wdt_write,
.ioctl = wdt_ioctl,
.open = wdt_open,
.release = wdt_release,
};
static struct miscdevice wdt_miscdev = {
minor: WATCHDOG_MINOR,
name: "watchdog",
fops: &wdt_fops,
.minor = WATCHDOG_MINOR,
.name = "watchdog",
.fops = &wdt_fops,
};
static char banner[] __initdata = KERN_INFO NAME ": Watchdog Timer version " VERSION "\n";

@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -602,6 +602,10 @@ config MIPS_AU1X00_ENET
@@ -479,6 +479,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@ -13,7 +13,7 @@
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -208,6 +208,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
@@ -207,6 +207,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o

@ -1,6 +1,6 @@
--- a/drivers/usb/host/adm5120-dbg.c
+++ b/drivers/usb/host/adm5120-dbg.c
@@ -642,7 +642,7 @@ static ssize_t fill_registers_buffer(str
@@ -644,7 +644,7 @@ static ssize_t fill_registers_buffer(str
hcd->product_desc,
hcd_name);

@ -35,7 +35,7 @@
struct admhcd *ahcd;
struct ed **seen, *ed;
unsigned long flags;
@@ -529,9 +523,7 @@ static ssize_t fill_periodic_buffer(stru
@@ -530,9 +524,7 @@ static ssize_t fill_periodic_buffer(stru
return 0;
seen_count = 0;
@ -46,7 +46,7 @@
next = buf->page;
size = PAGE_SIZE;
@@ -613,7 +605,6 @@ static ssize_t fill_periodic_buffer(stru
@@ -615,7 +607,6 @@ static ssize_t fill_periodic_buffer(stru
static ssize_t fill_registers_buffer(struct debug_buffer *buf)
{
@ -54,7 +54,7 @@
struct usb_hcd *hcd;
struct admhcd *ahcd;
struct admhcd_regs __iomem *regs;
@@ -622,9 +613,8 @@ static ssize_t fill_registers_buffer(str
@@ -624,9 +615,8 @@ static ssize_t fill_registers_buffer(str
char *next;
u32 rdata;
@ -66,7 +66,7 @@
regs = ahcd->regs;
next = buf->page;
size = PAGE_SIZE;
@@ -689,7 +679,7 @@ done:
@@ -691,7 +681,7 @@ done:
}
@ -75,7 +75,7 @@
ssize_t (*fill_func)(struct debug_buffer *))
{
struct debug_buffer *buf;
@@ -697,7 +687,7 @@ static struct debug_buffer *alloc_buffer
@@ -699,7 +689,7 @@ static struct debug_buffer *alloc_buffer
buf = kzalloc(sizeof(struct debug_buffer), GFP_KERNEL);
if (buf) {
@ -84,7 +84,7 @@
buf->fill_func = fill_func;
mutex_init(&buf->mutex);
}
@@ -790,26 +780,25 @@ static int debug_registers_open(struct i
@@ -792,26 +782,25 @@ static int debug_registers_open(struct i
static inline void create_debug_files(struct admhcd *ahcd)
{
struct usb_bus *bus = &admhcd_to_hcd(ahcd)->self;

@ -1,6 +1,6 @@
--- a/drivers/usb/host/adm5120-dbg.c
+++ b/drivers/usb/host/adm5120-dbg.c
@@ -642,7 +642,7 @@ static ssize_t fill_registers_buffer(str
@@ -644,7 +644,7 @@ static ssize_t fill_registers_buffer(str
hcd->product_desc,
hcd_name);

@ -35,7 +35,7 @@
struct admhcd *ahcd;
struct ed **seen, *ed;
unsigned long flags;
@@ -529,9 +523,7 @@ static ssize_t fill_periodic_buffer(stru
@@ -530,9 +524,7 @@ static ssize_t fill_periodic_buffer(stru
return 0;
seen_count = 0;
@ -46,7 +46,7 @@
next = buf->page;
size = PAGE_SIZE;
@@ -613,7 +605,6 @@ static ssize_t fill_periodic_buffer(stru
@@ -615,7 +607,6 @@ static ssize_t fill_periodic_buffer(stru
static ssize_t fill_registers_buffer(struct debug_buffer *buf)
{
@ -54,7 +54,7 @@
struct usb_hcd *hcd;
struct admhcd *ahcd;
struct admhcd_regs __iomem *regs;
@@ -622,9 +613,8 @@ static ssize_t fill_registers_buffer(str
@@ -624,9 +615,8 @@ static ssize_t fill_registers_buffer(str
char *next;
u32 rdata;
@ -66,7 +66,7 @@
regs = ahcd->regs;
next = buf->page;
size = PAGE_SIZE;
@@ -689,7 +679,7 @@ done:
@@ -691,7 +681,7 @@ done:
}
@ -75,7 +75,7 @@
ssize_t (*fill_func)(struct debug_buffer *))
{
struct debug_buffer *buf;
@@ -697,7 +687,7 @@ static struct debug_buffer *alloc_buffer
@@ -699,7 +689,7 @@ static struct debug_buffer *alloc_buffer
buf = kzalloc(sizeof(struct debug_buffer), GFP_KERNEL);
if (buf) {
@ -84,7 +84,7 @@
buf->fill_func = fill_func;
mutex_init(&buf->mutex);
}
@@ -790,26 +780,25 @@ static int debug_registers_open(struct i
@@ -792,26 +782,25 @@ static int debug_registers_open(struct i
static inline void create_debug_files(struct admhcd *ahcd)
{
struct usb_bus *bus = &admhcd_to_hcd(ahcd)->self;

@ -22,14 +22,14 @@
#define NO_IRQ (-1)
--- a/drivers/watchdog/adm5120_wdt.c
+++ b/drivers/watchdog/adm5120_wdt.c
@@ -167,7 +167,7 @@ static struct file_operations wdt_fops =
owner: THIS_MODULE,
llseek: no_llseek,
write: wdt_write,
- ioctl: wdt_ioctl,
+ unlocked_ioctl: wdt_ioctl,
open: wdt_open,
release: wdt_release,
@@ -166,7 +166,7 @@ static const struct file_operations wdt_
.owner = THIS_MODULE,
.llseek = no_llseek,
.write = wdt_write,
- .ioctl = wdt_ioctl,
+ .unlocked_ioctl = wdt_ioctl,
.open = wdt_open,
.release = wdt_release,
};
--- a/arch/mips/Kbuild.platforms
+++ b/arch/mips/Kbuild.platforms

Loading…
Cancel
Save