lantiq: fix patches after 3.14.32 bump

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 44320
v19.07.3_mercusys_ac12_duma
Luka Perkov 10 years ago
parent 7294b892dc
commit 683da1384b

@ -5516,7 +5516,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
(AER) driver support. Error reporting messages sent to Root (AER) driver support. Error reporting messages sent to Root
--- a/include/linux/pci.h --- a/include/linux/pci.h
+++ b/include/linux/pci.h +++ b/include/linux/pci.h
@@ -1121,6 +1121,8 @@ void pci_walk_bus(struct pci_bus *top, i @@ -1123,6 +1123,8 @@ void pci_walk_bus(struct pci_bus *top, i
void *userdata); void *userdata);
int pci_cfg_space_size(struct pci_dev *dev); int pci_cfg_space_size(struct pci_dev *dev);
unsigned char pci_bus_max_busnr(struct pci_bus *bus); unsigned char pci_bus_max_busnr(struct pci_bus *bus);

@ -14,7 +14,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
--- a/arch/mips/lantiq/xway/xrx200_phy_fw.c --- a/arch/mips/lantiq/xway/xrx200_phy_fw.c
+++ b/arch/mips/lantiq/xway/xrx200_phy_fw.c +++ b/arch/mips/lantiq/xway/xrx200_phy_fw.c
@@ -24,7 +24,23 @@ static dma_addr_t xway_gphy_load(struct @@ -24,7 +24,23 @@ static dma_addr_t xway_gphy_load(struct
void *fw_addr; void *fw_addr;
size_t size; size_t size;

@ -24,7 +24,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
int port = PORT(pin); int port = PORT(pin);
u32 alt1_reg = GPIO_ALT1(pin); u32 alt1_reg = GPIO_ALT1(pin);
@@ -632,6 +631,14 @@ static inline int xway_mux_apply(struct @@ -632,6 +631,14 @@ static inline int xway_mux_apply(struct
return 0; return 0;
} }

@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mtd/devices/m25p80.c --- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c +++ b/drivers/mtd/devices/m25p80.c
@@ -1105,6 +1105,10 @@ static int m25p_probe(struct spi_device @@ -1105,6 +1105,10 @@ static int m25p_probe(struct spi_device
struct mtd_part_parser_data ppdata; struct mtd_part_parser_data ppdata;
struct device_node *np = spi->dev.of_node; struct device_node *np = spi->dev.of_node;
int ret; int ret;
@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/* Platform data helps sort out which chip type we have, as /* Platform data helps sort out which chip type we have, as
* well as how this board partitions it. If we don't have * well as how this board partitions it. If we don't have
@@ -1177,6 +1181,8 @@ static int m25p_probe(struct spi_device @@ -1177,6 +1181,8 @@ static int m25p_probe(struct spi_device
if (data && data->name) if (data && data->name)
flash->mtd.name = data->name; flash->mtd.name = data->name;

@ -13,9 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/net/phy/Kconfig --- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig +++ b/drivers/net/phy/Kconfig
@@ -157,6 +157,11 @@ config MICREL_PHY @@ -152,6 +152,11 @@ config RTL8306_PHY
---help--- tristate "Driver for Realtek RTL8306S switches"
Currently has a driver for the KSZ8041 select SWCONFIG
+config LANTIQ_PHY +config LANTIQ_PHY
+ tristate "Driver for Lantiq PHYs" + tristate "Driver for Lantiq PHYs"
@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on PHYLIB=y depends on PHYLIB=y
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -40,6 +40,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o @@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_DP83640_PHY) += dp83640.o obj-$(CONFIG_DP83640_PHY) += dp83640.o
obj-$(CONFIG_STE10XP) += ste10Xp.o obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_MICREL_PHY) += micrel.o obj-$(CONFIG_MICREL_PHY) += micrel.o

@ -21,7 +21,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
phydev->adjust_link(phydev->attached_dev); phydev->adjust_link(phydev->attached_dev);
break; break;
} }
@@ -830,7 +831,8 @@ void phy_state_machine(struct work_struc @@ -841,7 +842,8 @@ void phy_state_machine(struct work_struc
netif_carrier_on(phydev->attached_dev); netif_carrier_on(phydev->attached_dev);
} else { } else {
phydev->state = PHY_NOLINK; phydev->state = PHY_NOLINK;
@ -31,7 +31,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
} }
phydev->adjust_link(phydev->attached_dev); phydev->adjust_link(phydev->attached_dev);
@@ -842,7 +844,8 @@ void phy_state_machine(struct work_struc @@ -853,7 +855,8 @@ void phy_state_machine(struct work_struc
case PHY_HALTED: case PHY_HALTED:
if (phydev->link) { if (phydev->link) {
phydev->link = 0; phydev->link = 0;
@ -39,7 +39,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ if (!phydev->no_auto_carrier_off) + if (!phydev->no_auto_carrier_off)
+ netif_carrier_off(phydev->attached_dev); + netif_carrier_off(phydev->attached_dev);
phydev->adjust_link(phydev->attached_dev); phydev->adjust_link(phydev->attached_dev);
do_suspend = 1; do_suspend = true;
} }
--- a/include/linux/phy.h --- a/include/linux/phy.h
+++ b/include/linux/phy.h +++ b/include/linux/phy.h

@ -265,7 +265,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
return IRQ_HANDLED; return IRQ_HANDLED;
} }
@@ -224,7 +301,7 @@ ltq_etop_free_channel(struct net_device @@ -224,7 +301,7 @@ ltq_etop_free_channel(struct net_device
ltq_dma_free(&ch->dma); ltq_dma_free(&ch->dma);
if (ch->dma.irq) if (ch->dma.irq)
free_irq(ch->dma.irq, priv); free_irq(ch->dma.irq, priv);
@ -442,7 +442,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
} }
static void static void
@@ -309,7 +454,10 @@ ltq_etop_get_settings(struct net_device @@ -309,7 +454,10 @@ ltq_etop_get_settings(struct net_device
{ {
struct ltq_etop_priv *priv = netdev_priv(dev); struct ltq_etop_priv *priv = netdev_priv(dev);
@ -454,7 +454,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
} }
static int static int
@@ -317,7 +465,10 @@ ltq_etop_set_settings(struct net_device @@ -317,7 +465,10 @@ ltq_etop_set_settings(struct net_device
{ {
struct ltq_etop_priv *priv = netdev_priv(dev); struct ltq_etop_priv *priv = netdev_priv(dev);
@ -675,7 +675,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
return 0; return 0;
} }
@@ -520,16 +716,16 @@ ltq_etop_tx(struct sk_buff *skb, struct @@ -520,16 +716,16 @@ ltq_etop_tx(struct sk_buff *skb, struct
int queue = skb_get_queue_mapping(skb); int queue = skb_get_queue_mapping(skb);
struct netdev_queue *txq = netdev_get_tx_queue(dev, queue); struct netdev_queue *txq = netdev_get_tx_queue(dev, queue);
struct ltq_etop_priv *priv = netdev_priv(dev); struct ltq_etop_priv *priv = netdev_priv(dev);
@ -697,7 +697,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
netdev_err(dev, "tx ring full\n"); netdev_err(dev, "tx ring full\n");
netif_tx_stop_queue(txq); netif_tx_stop_queue(txq);
return NETDEV_TX_BUSY; return NETDEV_TX_BUSY;
@@ -537,7 +733,7 @@ ltq_etop_tx(struct sk_buff *skb, struct @@ -537,7 +733,7 @@ ltq_etop_tx(struct sk_buff *skb, struct
/* dma needs to start on a 16 byte aligned address */ /* dma needs to start on a 16 byte aligned address */
byte_offset = CPHYSADDR(skb->data) % 16; byte_offset = CPHYSADDR(skb->data) % 16;
@ -706,7 +706,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
dev->trans_start = jiffies; dev->trans_start = jiffies;
@@ -547,11 +743,11 @@ ltq_etop_tx(struct sk_buff *skb, struct @@ -547,11 +743,11 @@ ltq_etop_tx(struct sk_buff *skb, struct
wmb(); wmb();
desc->ctl = LTQ_DMA_OWN | LTQ_DMA_SOP | LTQ_DMA_EOP | desc->ctl = LTQ_DMA_OWN | LTQ_DMA_SOP | LTQ_DMA_EOP |
LTQ_DMA_TX_OFFSET(byte_offset) | (len & LTQ_DMA_SIZE_MASK); LTQ_DMA_TX_OFFSET(byte_offset) | (len & LTQ_DMA_SIZE_MASK);

@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
struct gpio_desc; struct gpio_desc;
@@ -296,3 +298,69 @@ void of_gpiochip_remove(struct gpio_chip @@ -302,3 +304,69 @@ void of_gpiochip_remove(struct gpio_chip
if (chip->of_node) if (chip->of_node)
of_node_put(chip->of_node); of_node_put(chip->of_node);
} }
@ -94,7 +94,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+device_initcall(of_gpio_export_init); +device_initcall(of_gpio_export_init);
--- a/drivers/gpio/gpiolib.c --- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c +++ b/drivers/gpio/gpiolib.c
@@ -803,7 +803,7 @@ static struct class gpio_class = { @@ -798,7 +798,7 @@ static struct class gpio_class = {
* *
* Returns zero on success, else an error. * Returns zero on success, else an error.
*/ */
@ -103,17 +103,17 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
{ {
unsigned long flags; unsigned long flags;
int status; int status;
@@ -843,7 +843,8 @@ int gpiod_export(struct gpio_desc *desc, @@ -839,6 +839,9 @@ int gpiod_export(struct gpio_desc *desc,
offset = gpio_chip_hwgpio(desc);
if (desc->chip->names && desc->chip->names[offset]) if (desc->chip->names && desc->chip->names[offset])
ioname = desc->chip->names[offset]; ioname = desc->chip->names[offset];
-
+ if (name) + if (name)
+ ioname = name; + ioname = name;
dev = device_create(&gpio_class, desc->chip->dev, MKDEV(0, 0), +
desc, ioname ? ioname : "gpio%u", dev = device_create_with_groups(&gpio_class, desc->chip->dev,
desc_to_gpio(desc)); MKDEV(0, 0), desc, gpio_groups,
@@ -880,6 +881,12 @@ fail_unlock: ioname ? ioname : "gpio%u",
@@ -874,6 +877,12 @@ fail_unlock:
gpiod_dbg(desc, "%s: status %d\n", __func__, status); gpiod_dbg(desc, "%s: status %d\n", __func__, status);
return status; return status;
} }

@ -19,10 +19,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
create mode 100644 arch/mips/lantiq/xway/pci-ath-fixup.c create mode 100644 arch/mips/lantiq/xway/pci-ath-fixup.c
create mode 100644 arch/mips/lantiq/xway/rt_eep.c create mode 100644 arch/mips/lantiq/xway/rt_eep.c
Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h --- /dev/null
=================================================================== +++ b/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.14.28/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h 2015-01-17 10:55:03.329443942 -0800
@@ -0,0 +1,6 @@ @@ -0,0 +1,6 @@
+#ifndef _PCI_ATH_FIXUP +#ifndef _PCI_ATH_FIXUP
+#define _PCI_ATH_FIXUP +#define _PCI_ATH_FIXUP
@ -30,11 +28,9 @@ Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/pci-ath-fixup.h
+void ltq_pci_ath_fixup(unsigned slot, u16 *cal_data) __init; +void ltq_pci_ath_fixup(unsigned slot, u16 *cal_data) __init;
+ +
+#endif /* _PCI_ATH_FIXUP */ +#endif /* _PCI_ATH_FIXUP */
Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h --- a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
=================================================================== +++ b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
--- linux-3.14.28.orig/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h 2015-01-17 10:55:03.337443971 -0800 @@ -90,5 +90,8 @@ int xrx200_gphy_boot(struct device *dev,
+++ linux-3.14.28/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h 2015-01-17 10:55:03.329443942 -0800
@@ -90,5 +90,8 @@
extern void ltq_pmu_enable(unsigned int module); extern void ltq_pmu_enable(unsigned int module);
extern void ltq_pmu_disable(unsigned int module); extern void ltq_pmu_disable(unsigned int module);
@ -43,11 +39,9 @@ Index: linux-3.14.28/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
+ +
#endif /* CONFIG_SOC_TYPE_XWAY */ #endif /* CONFIG_SOC_TYPE_XWAY */
#endif /* _LTQ_XWAY_H__ */ #endif /* _LTQ_XWAY_H__ */
Index: linux-3.14.28/arch/mips/lantiq/xway/Makefile --- a/arch/mips/lantiq/xway/Makefile
=================================================================== +++ b/arch/mips/lantiq/xway/Makefile
--- linux-3.14.28.orig/arch/mips/lantiq/xway/Makefile 2015-01-17 10:55:03.337443971 -0800 @@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
+++ linux-3.14.28/arch/mips/lantiq/xway/Makefile 2015-01-17 11:58:16.000000000 -0800
@@ -2,4 +2,7 @@
obj-y += vmmc.o tffs.o obj-y += vmmc.o tffs.o
@ -55,10 +49,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/Makefile
+obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o pci-ath-fixup.o +obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o pci-ath-fixup.o
+ +
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
Index: linux-3.14.28/arch/mips/lantiq/xway/ath_eep.c --- /dev/null
=================================================================== +++ b/arch/mips/lantiq/xway/ath_eep.c
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.14.28/arch/mips/lantiq/xway/ath_eep.c 2015-01-17 10:55:03.329443942 -0800
@@ -0,0 +1,282 @@ @@ -0,0 +1,282 @@
+/* +/*
+ * Copyright (C) 2011 Luca Olivetti <luca@ventoso.org> + * Copyright (C) 2011 Luca Olivetti <luca@ventoso.org>
@ -342,10 +334,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/ath_eep.c
+ return platform_driver_probe(&ath5k_eeprom_driver, of_ath5k_eeprom_probe); + return platform_driver_probe(&ath5k_eeprom_driver, of_ath5k_eeprom_probe);
+} +}
+device_initcall(of_ath5k_eeprom_init); +device_initcall(of_ath5k_eeprom_init);
Index: linux-3.14.28/arch/mips/lantiq/xway/eth_mac.c --- /dev/null
=================================================================== +++ b/arch/mips/lantiq/xway/eth_mac.c
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.14.28/arch/mips/lantiq/xway/eth_mac.c 2015-01-17 11:14:42.823292726 -0800
@@ -0,0 +1,76 @@ @@ -0,0 +1,76 @@
+/* +/*
+ * Copyright (C) 2012 John Crispin <blogic@openwrt.org> + * Copyright (C) 2012 John Crispin <blogic@openwrt.org>
@ -423,10 +413,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/eth_mac.c
+ return platform_driver_probe(&eth_mac_driver, of_eth_mac_probe); + return platform_driver_probe(&eth_mac_driver, of_eth_mac_probe);
+} +}
+device_initcall(of_eth_mac_init); +device_initcall(of_eth_mac_init);
Index: linux-3.14.28/arch/mips/lantiq/xway/pci-ath-fixup.c --- /dev/null
=================================================================== +++ b/arch/mips/lantiq/xway/pci-ath-fixup.c
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.14.28/arch/mips/lantiq/xway/pci-ath-fixup.c 2015-01-17 10:55:03.329443942 -0800
@@ -0,0 +1,109 @@ @@ -0,0 +1,109 @@
+/* +/*
+ * Atheros AP94 reference board PCI initialization + * Atheros AP94 reference board PCI initialization
@ -537,10 +525,8 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/pci-ath-fixup.c
+ ath_fixups[ath_num_fixups].cal_data = cal_data; + ath_fixups[ath_num_fixups].cal_data = cal_data;
+ ath_num_fixups++; + ath_num_fixups++;
+} +}
Index: linux-3.14.28/arch/mips/lantiq/xway/rt_eep.c --- /dev/null
=================================================================== +++ b/arch/mips/lantiq/xway/rt_eep.c
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-3.14.28/arch/mips/lantiq/xway/rt_eep.c 2015-01-17 10:55:03.329443942 -0800
@@ -0,0 +1,60 @@ @@ -0,0 +1,60 @@
+/* +/*
+ * Copyright (C) 2011 John Crispin <blogic@openwrt.org> + * Copyright (C) 2011 John Crispin <blogic@openwrt.org>
@ -602,11 +588,9 @@ Index: linux-3.14.28/arch/mips/lantiq/xway/rt_eep.c
+ return platform_driver_probe(&ralink_eeprom_driver, of_ralink_eeprom_probe); + return platform_driver_probe(&ralink_eeprom_driver, of_ralink_eeprom_probe);
+} +}
+device_initcall(of_ralink_eeprom_init); +device_initcall(of_ralink_eeprom_init);
Index: linux-3.14.28/drivers/net/ethernet/lantiq_etop.c --- a/drivers/net/ethernet/lantiq_etop.c
=================================================================== +++ b/drivers/net/ethernet/lantiq_etop.c
--- linux-3.14.28.orig/drivers/net/ethernet/lantiq_etop.c 2015-01-17 11:52:03.818405214 -0800 @@ -843,6 +843,9 @@ ltq_etop_init(struct net_device *dev)
+++ linux-3.14.28/drivers/net/ethernet/lantiq_etop.c 2015-01-17 12:02:20.905465188 -0800
@@ -843,6 +843,9 @@
if (priv->mac) if (priv->mac)
memcpy(&mac.sa_data, priv->mac, ETH_ALEN); memcpy(&mac.sa_data, priv->mac, ETH_ALEN);

@ -5,9 +5,9 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
arch/mips/lantiq/xway/clk.c | 5 +++-- arch/mips/lantiq/xway/clk.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-) 1 file changed, 3 insertions(+), 2 deletions(-)
--- a/arch/mips/lantiq/xway/clk.c 2015-01-21 10:15:44.000000000 +0100 --- a/arch/mips/lantiq/xway/clk.c
+++ b/arch/mips/lantiq/xway/clk.c 2015-01-21 10:17:29.000000000 +0100 +++ b/arch/mips/lantiq/xway/clk.c
@@ -104,8 +104,9 @@ unsigned long ltq_ar9_fpi_hz(void) @@ -87,8 +87,9 @@ unsigned long ltq_ar9_fpi_hz(void)
unsigned long sys = ltq_ar9_sys_hz(); unsigned long sys = ltq_ar9_sys_hz();
if (ltq_cgu_r32(CGU_SYS) & BIT(0)) if (ltq_cgu_r32(CGU_SYS) & BIT(0))

Loading…
Cancel
Save