refresh patches

SVN-Revision: 16444
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 15 years ago
parent b63576359d
commit 567b6d1a27

@ -21,11 +21,9 @@ Signed-off-by: Wu Zhangjin <wuzhangjin@gmail.com>
arch/mips/include/asm/delay.h | 58 +++++++++++++++++++++++++------------ arch/mips/include/asm/delay.h | 58 +++++++++++++++++++++++++------------
3 files changed, 57 insertions(+), 20 deletions(-) 3 files changed, 57 insertions(+), 20 deletions(-)
diff --git a/arch/mips/Makefile b/arch/mips/Makefile
index a25c2e5..1ee5504 100644
--- a/arch/mips/Makefile --- a/arch/mips/Makefile
+++ b/arch/mips/Makefile +++ b/arch/mips/Makefile
@@ -120,7 +120,14 @@ cflags-$(CONFIG_CPU_R4300) += -march=r4300 -Wa,--trap @@ -119,7 +119,14 @@ cflags-$(CONFIG_CPU_R4300) += -march=r43
cflags-$(CONFIG_CPU_VR41XX) += -march=r4100 -Wa,--trap cflags-$(CONFIG_CPU_VR41XX) += -march=r4100 -Wa,--trap
cflags-$(CONFIG_CPU_R4X00) += -march=r4600 -Wa,--trap cflags-$(CONFIG_CPU_R4X00) += -march=r4600 -Wa,--trap
cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
@ -41,8 +39,6 @@ index a25c2e5..1ee5504 100644
cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \ cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
-Wa,-mips32 -Wa,--trap -Wa,-mips32 -Wa,--trap
cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \ cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
diff --git a/arch/mips/include/asm/compiler.h b/arch/mips/include/asm/compiler.h
index 71f5c5c..95256a8 100644
--- a/arch/mips/include/asm/compiler.h --- a/arch/mips/include/asm/compiler.h
+++ b/arch/mips/include/asm/compiler.h +++ b/arch/mips/include/asm/compiler.h
@@ -1,5 +1,6 @@ @@ -1,5 +1,6 @@
@ -66,8 +62,6 @@ index 71f5c5c..95256a8 100644
+#endif +#endif
+ +
#endif /* _ASM_COMPILER_H */ #endif /* _ASM_COMPILER_H */
diff --git a/arch/mips/include/asm/delay.h b/arch/mips/include/asm/delay.h
index b0bccd2..00d7969 100644
--- a/arch/mips/include/asm/delay.h --- a/arch/mips/include/asm/delay.h
+++ b/arch/mips/include/asm/delay.h +++ b/arch/mips/include/asm/delay.h
@@ -7,6 +7,7 @@ @@ -7,6 +7,7 @@
@ -78,7 +72,7 @@ index b0bccd2..00d7969 100644
*/ */
#ifndef _ASM_DELAY_H #ifndef _ASM_DELAY_H
#define _ASM_DELAY_H #define _ASM_DELAY_H
@@ -48,6 +49,43 @@ static inline void __delay(unsigned long loops) @@ -48,6 +49,43 @@ static inline void __delay(unsigned long
: "0" (loops), "r" (1)); : "0" (loops), "r" (1));
} }
@ -122,7 +116,7 @@ index b0bccd2..00d7969 100644
/* /*
* Division by multiplication: you don't have to worry about * Division by multiplication: you don't have to worry about
@@ -62,8 +100,6 @@ static inline void __delay(unsigned long loops) @@ -62,8 +100,6 @@ static inline void __delay(unsigned long
static inline void __udelay(unsigned long usecs, unsigned long lpj) static inline void __udelay(unsigned long usecs, unsigned long lpj)
{ {
@ -131,7 +125,7 @@ index b0bccd2..00d7969 100644
/* /*
* The rates of 128 is rounded wrongly by the catchall case * The rates of 128 is rounded wrongly by the catchall case
* for 64-bit. Excessive precission? Probably ... * for 64-bit. Excessive precission? Probably ...
@@ -77,23 +113,7 @@ static inline void __udelay(unsigned long usecs, unsigned long lpj) @@ -77,23 +113,7 @@ static inline void __udelay(unsigned lon
0x80000000ULL) >> 32); 0x80000000ULL) >> 32);
#endif #endif
@ -156,8 +150,3 @@ index b0bccd2..00d7969 100644
} }
#define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val #define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
--
1.6.0.4

@ -1,6 +1,6 @@
--- a/arch/mips/Makefile --- a/arch/mips/Makefile
+++ b/arch/mips/Makefile +++ b/arch/mips/Makefile
@@ -586,6 +586,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927) += arch/ @@ -593,6 +593,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927) += arch/
core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/ core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
core-$(CONFIG_TOSHIBA_RBTX4939) += arch/mips/txx9/rbtx4939/ core-$(CONFIG_TOSHIBA_RBTX4939) += arch/mips/txx9/rbtx4939/

@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr, RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow, .napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_MSI .features = RTL_FEATURE_MSI
@@ -3554,10 +3554,12 @@ static irqreturn_t rtl8169_interrupt(int @@ -3555,10 +3555,12 @@ static irqreturn_t rtl8169_interrupt(int
goto out; goto out;
} }

@ -67,7 +67,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -5015,6 +5015,7 @@ int can_nice(const struct task_struct *p @@ -5064,6 +5064,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur || return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }

@ -132,7 +132,7 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -802,6 +802,9 @@ config MIPS_DISABLE_OBSOLETE_IDE @@ -803,6 +803,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K config SYNC_R4K
bool bool

@ -1,6 +1,6 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -804,6 +804,9 @@ config SYNC_R4K @@ -805,6 +805,9 @@ config SYNC_R4K
config MIPS_MACHINE config MIPS_MACHINE
def_bool n def_bool n

@ -6,8 +6,6 @@ Signed-off-by: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
arch/mips/lib/delay.c | 4 ++-- arch/mips/lib/delay.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-) 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/mips/lib/delay.c b/arch/mips/lib/delay.c
index f69c6b5..6b3b1de 100644
--- a/arch/mips/lib/delay.c --- a/arch/mips/lib/delay.c
+++ b/arch/mips/lib/delay.c +++ b/arch/mips/lib/delay.c
@@ -43,7 +43,7 @@ void __udelay(unsigned long us) @@ -43,7 +43,7 @@ void __udelay(unsigned long us)
@ -27,6 +25,3 @@ index f69c6b5..6b3b1de 100644
+ __delay((ns * 0x00000005ull * HZ * lpj) >> 32); + __delay((ns * 0x00000005ull * HZ * lpj) >> 32);
} }
EXPORT_SYMBOL(__ndelay); EXPORT_SYMBOL(__ndelay);

Loading…
Cancel
Save