iproute2: workaround compile issues with gcc 4.8.x

SVN-Revision: 36642
v19.07.3_mercusys_ac12_duma
Luka Perkov 11 years ago
parent a62ca72309
commit 4fc8e64a40

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=3.9.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/

@ -0,0 +1,12 @@
--- a/Makefile
+++ b/Makefile
@@ -30,8 +30,7 @@ CC = gcc
HOSTCC = gcc
DEFINES += -D_GNU_SOURCE
CCOPTS = -O2
-WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
-WFLAGS += -Wmissing-declarations -Wold-style-definition
+WFLAGS := -Wall -Wstrict-prototypes
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
YACCFLAGS = -d -t -v

@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
@@ -35,7 +35,7 @@ WFLAGS := -Wall -Wstrict-prototypes
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
YACCFLAGS = -d -t -v

@ -6,6 +6,6 @@
DEFINES += -D_GNU_SOURCE
-CCOPTS = -O2
+CCOPTS = -O2 $(EXTRA_CCOPTS)
WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
WFLAGS += -Wmissing-declarations -Wold-style-definition
WFLAGS := -Wall -Wstrict-prototypes
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)

Loading…
Cancel
Save