You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/network/utils/iproute2/patches/000-warnings.patch

13 lines
349 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -30,8 +30,7 @@ CC = gcc
HOSTCC = gcc
DEFINES += -D_GNU_SOURCE
CCOPTS = -O2
-WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
-WFLAGS += -Wmissing-declarations -Wold-style-definition
+WFLAGS := -Wall -Wstrict-prototypes
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
YACCFLAGS = -d -t -v