update to 2.6.37.1

SVN-Revision: 25577
v19.07.3_mercusys_ac12_duma
Florian Fainelli 14 years ago
parent a0ee5b91fd
commit 3cd87d2d81

@ -20,8 +20,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.36.2) ifeq ($(LINUX_VERSION),2.6.36.2)
LINUX_KERNEL_MD5SUM:=d465f8ba05bf1b7530c596f1cca658e7 LINUX_KERNEL_MD5SUM:=d465f8ba05bf1b7530c596f1cca658e7
endif endif
ifeq ($(LINUX_VERSION),2.6.37) ifeq ($(LINUX_VERSION),2.6.37.1)
LINUX_KERNEL_MD5SUM:=c8ee37b4fdccdb651e0603d35350b434 LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
endif endif
# disable the md5sum check for unknown kernel versions # disable the md5sum check for unknown kernel versions

@ -105,7 +105,7 @@
{ {
--- a/fs/partitions/check.c --- a/fs/partitions/check.c
+++ b/fs/partitions/check.c +++ b/fs/partitions/check.c
@@ -707,6 +707,7 @@ rescan: @@ -715,6 +715,7 @@ rescan:
kfree(state); kfree(state);
return 0; return 0;
} }

@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size; port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress; port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL); port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
@@ -1388,3 +1389,5 @@ MODULE_LICENSE("GPL"); @@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
module_param(debug, bool, S_IRUGO | S_IWUSR); module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not"); MODULE_PARM_DESC(debug, "Debug enabled or not");

@ -76,7 +76,7 @@
* macro override instead of weak attribute alias, to workaround * macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c --- a/kernel/sched.c
+++ b/kernel/sched.c +++ b/kernel/sched.c
@@ -4773,6 +4773,7 @@ int can_nice(const struct task_struct *p @@ -4776,6 +4776,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) || return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
capable(CAP_SYS_NICE)); capable(CAP_SYS_NICE));
} }

@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
SUBTARGETS:=le be SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:= INITRAMFS_EXTRA_FILES:=
LINUX_VERSION:=2.6.37 LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
MAINTAINER:=Michael Buesch <mb@bu3sch.de> MAINTAINER:=Michael Buesch <mb@bu3sch.de>
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
LINUX_VERSION:=2.6.37 LINUX_VERSION:=2.6.37.1
define Target/Description define Target/Description
TI OMAP-24xx TI OMAP-24xx

@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org> MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=2.6.37 LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
FEATURES:=squashfs jffs2 fpu FEATURES:=squashfs jffs2 fpu
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
LINUX_VERSION:=2.6.37 LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext4 audio FEATURES:=ext4 audio
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH) LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
LINUX_VERSION:=2.6.37 LINUX_VERSION:=2.6.37.1
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=jffs2 targz ubifs audio FEATURES:=jffs2 targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt SUBTARGETS:=qi_lb60 n516 n526 id800wt
LINUX_VERSION:=2.6.37 LINUX_VERSION:=2.6.37.1
DEVICE_TYPE=other DEVICE_TYPE=other

Loading…
Cancel
Save