uboot-mvebu: switch to u-boot.mk

Signed-off-by: Felix Fietkau <nbd@nbd.name>
v19.07.3_mercusys_ac12_duma
Felix Fietkau 7 years ago
parent 608d36e423
commit 366c33962c

@ -8,90 +8,31 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
PKG_VERSION:=2016.03 PKG_VERSION:=2016.03
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=\
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb
PKG_LICENSE:=GPL-2.0 GPL-2.0+ include $(INCLUDE_DIR)/u-boot.mk
PKG_LICENSE_FILES:=Licenses/README
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define uboot/Default define U-Boot/Default
TITLE:= BUILD_TARGET:=mvebu
endef
define uboot/clearfog
TITLE:=U-Boot for SolidRun ClearFog A1
DEVICE:=armada-388-clearfog
endef
UBOOTS:= \
clearfog
define Package/uboot/template
define Package/uboot-mvebu-$(1)
SECTION:=boot
CATEGORY:=Boot Loaders
DEPENDS:=@(TARGET_DEVICE_mvebu_DEVICE_$(3)||TARGET_mvebu_DEVICE_$(3)||TARGET_mvebu_Default)
DEFAULT:=m
HIDDEN:=1 HIDDEN:=1
TITLE:=$(2)
URL:=http://www.denx.de/wiki/U-Boot
VARIANT:=$(1)
MAINTAINER:=Felix Fietkau <nbd@nbd.name>
endef
endef endef
define BuildUBootPackage define U-Boot/clearfog
$(eval $(uboot/Default)) NAME:=SolidRun ClearFog A1
$(eval $(uboot/$(1))) BUILD_DEVICES:=armada-388-clearfog
$(call Package/uboot/template,$(1),$(TITLE),$(DEVICE)) UBOOT_IMAGE:=u-boot-spl.kwb
endef endef
define Build/Configure UBOOT_TARGETS:= \
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \ clearfog
$(BUILD_VARIANT)_config
endef
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
DTC_DIR=$(LINUX_DIR)/scripts/dtc/
endef
define Package/uboot/install/default define Build/InstallDev
$(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
$(CP) $(PKG_BUILD_DIR)/u-boot-spl.kwb \
$(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-spl.kwb
$(INSTALL_DIR) $(KERNEL_BUILD_DIR)/ $(INSTALL_DIR) $(KERNEL_BUILD_DIR)/
$(CP) $(PKG_BUILD_DIR)/u-boot-spl.kwb \ $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-u-boot-spl.kwb
$(KERNEL_BUILD_DIR)/openwrt-$(BOARD)-$(1)-u-boot-spl.kwb
$(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
$(CP) $(PKG_BUILD_DIR)/tools/kwboot \
$(BIN_DIR)/u-boot-kwboot/
endef endef
define Package/uboot/install/template $(eval $(call BuildPackage/U-Boot))
define Package/uboot-mvebu-$(1)/install
$(call Package/uboot/install/default,$(2))
endef
endef
$(foreach u,$(UBOOTS), \
$(eval $(call Package/uboot/install/template,$(u),$(u))) \
)
$(foreach u,$(UBOOTS), \
$(eval $(call BuildUBootPackage,$(u))) \
$(eval $(call BuildPackage,uboot-mvebu-$(u))) \
)

@ -1,11 +0,0 @@
--- a/Makefile
+++ b/Makefile
@@ -348,7 +348,7 @@ OBJDUMP = $(CROSS_COMPILE)objdump
AWK = awk
PERL = perl
PYTHON = python
-DTC = dtc
+DTC = $(DTC_DIR)dtc
CHECK = sparse
CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \

@ -39,7 +39,7 @@ endef
define Build/sdcard-img define Build/sdcard-img
ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \ ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
./gen_mvebu_sdcard_img.sh $@ \ ./gen_mvebu_sdcard_img.sh $@ \
"$(KDIR)/openwrt-mvebu-clearfog-u-boot-spl.kwb" \ "$(KDIR)/clearfog-u-boot-spl.kwb" \
c 32768 $@.boot \ c 32768 $@.boot \
83 $$ROOTFS_SIZE $(IMAGE_ROOTFS) 83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
endef endef

@ -7,7 +7,7 @@
define Profile/Default define Profile/Default
NAME:=Default Profile (all drivers) NAME:=Default Profile (all drivers)
PACKAGES:= kmod-mwlwifi wpad-mini swconfig uboot-mvebu-clearfog mkf2fs e2fsprogs PACKAGES:= kmod-mwlwifi wpad-mini swconfig mkf2fs e2fsprogs
endef endef
define Profile/Default/Description define Profile/Default/Description

Loading…
Cancel
Save