iproute2: update to 5.0.0

Update iproute2 to 5.0.0
Remove upstream patch 001-tc-fix-undefined-XATTR_SIZE_MAX
Alter patch 170-ip_tiny as support for IPX and DECnet is dropped
Update patch 010-cake-fwmark to match upstream commit

Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
v19.07.3_mercusys_ac12_duma
Deng Qingfang 5 years ago committed by Hans Dedecker
parent 8568dcd931
commit 31078dbc76

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2 PKG_NAME:=iproute2
PKG_VERSION:=4.20.0 PKG_VERSION:=5.0.0
PKG_RELEASE:=3 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
PKG_HASH:=c8adaa6a40f888476b23acb283cfa30c0dd55f07b5aa20663ed5ba2ef1f6fda8 PKG_HASH:=df047302a39650ef832c07e8dab5df7a23218cd398bd310c8628e386161d20ba
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0 PKG_LICENSE:=GPL-2.0

@ -1,10 +0,0 @@
--- a/tc/f_flower.c
+++ b/tc/f_flower.c
@@ -17,6 +17,7 @@
#include <linux/if_arp.h>
#include <linux/if_ether.h>
#include <linux/ip.h>
+#include <linux/limits.h>
#include <linux/tc_act/tc_vlan.h>
#include <linux/mpls.h>

@ -1,21 +1,18 @@
From 9572f793e6945dd90a3cd4db34814b9b1616cfe9 Mon Sep 17 00:00:00 2001 From a7cd7badedcb643dc1adb41edeb4cf8e4d9ec063 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Toke=20H=C3=B8iland-J=C3=B8rgensen?= <toke@toke.dk> From: Stephen Hemminger <stephen@networkplumber.org>
Date: Mon, 18 Mar 2019 01:30:19 +0100 Date: Tue, 19 Mar 2019 10:36:56 -0700
Subject: [PATCH] pkt_sched.h: Add support for CAKE FWMARK Subject: uapi: add CAKE FWMARK
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk> Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
--- ---
include/uapi/linux/pkt_sched.h | 1 + include/uapi/linux/pkt_sched.h | 1 +
1 file changed, 1 insertion(+) 1 file changed, 1 insertion(+)
diff --git a/include/uapi/linux/pkt_sched.h b/include/uapi/linux/pkt_sched.h diff --git a/include/uapi/linux/pkt_sched.h b/include/uapi/linux/pkt_sched.h
index 01f96352..ef78de0c 100644 index 1eb572e..7ee74c3 100644
--- a/include/uapi/linux/pkt_sched.h --- a/include/uapi/linux/pkt_sched.h
+++ b/include/uapi/linux/pkt_sched.h +++ b/include/uapi/linux/pkt_sched.h
@@ -954,6 +954,7 @@ enum { @@ -1021,6 +1021,7 @@ enum {
TCA_CAKE_INGRESS, TCA_CAKE_INGRESS,
TCA_CAKE_ACK_FILTER, TCA_CAKE_ACK_FILTER,
TCA_CAKE_SPLIT_GSO, TCA_CAKE_SPLIT_GSO,

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -61,7 +61,7 @@ WFLAGS += -Wmissing-declarations -Wold-s @@ -55,7 +55,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS) CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
YACCFLAGS = -d -t -v YACCFLAGS = -d -t -v

@ -7,7 +7,7 @@ Author: Cyril Brulebois <cyril@debamax.com>
Last-Update: 2017-11-22 Last-Update: 2017-11-22
--- a/include/xtables.h --- a/include/xtables.h
+++ b/include/xtables.h +++ b/include/xtables.h
@@ -205,9 +205,24 @@ enum xtables_ext_flags { @@ -206,9 +206,24 @@ enum xtables_ext_flags {
XTABLES_EXT_ALIAS = 1 << 0, XTABLES_EXT_ALIAS = 1 << 0,
}; };
@ -34,7 +34,7 @@ Last-Update: 2017-11-22
/* /*
* ABI/API version this module requires. Must be first member, * ABI/API version this module requires. Must be first member,
* as the rest of this struct may be subject to ABI changes. * as the rest of this struct may be subject to ABI changes.
@@ -269,6 +284,10 @@ struct xtables_match @@ -270,6 +285,10 @@ struct xtables_match
void (*x6_fcheck)(struct xt_fcheck_call *); void (*x6_fcheck)(struct xt_fcheck_call *);
const struct xt_option_entry *x6_options; const struct xt_option_entry *x6_options;
@ -45,7 +45,7 @@ Last-Update: 2017-11-22
/* Size of per-extension instance extra "global" scratch space */ /* Size of per-extension instance extra "global" scratch space */
size_t udata_size; size_t udata_size;
@@ -280,8 +299,7 @@ struct xtables_match @@ -281,8 +300,7 @@ struct xtables_match
unsigned int loaded; /* simulate loading so options are merged properly */ unsigned int loaded; /* simulate loading so options are merged properly */
}; };
@ -55,7 +55,7 @@ Last-Update: 2017-11-22
/* /*
* ABI/API version this module requires. Must be first member, * ABI/API version this module requires. Must be first member,
* as the rest of this struct may be subject to ABI changes. * as the rest of this struct may be subject to ABI changes.
@@ -346,6 +364,10 @@ struct xtables_target @@ -347,6 +365,10 @@ struct xtables_target
void (*x6_fcheck)(struct xt_fcheck_call *); void (*x6_fcheck)(struct xt_fcheck_call *);
const struct xt_option_entry *x6_options; const struct xt_option_entry *x6_options;
@ -66,7 +66,7 @@ Last-Update: 2017-11-22
size_t udata_size; size_t udata_size;
/* Ignore these men behind the curtain: */ /* Ignore these men behind the curtain: */
@@ -406,6 +428,17 @@ struct xtables_globals @@ -407,6 +429,17 @@ struct xtables_globals
#define XT_GETOPT_TABLEEND {.name = NULL, .has_arg = false} #define XT_GETOPT_TABLEEND {.name = NULL, .has_arg = false}
@ -84,7 +84,7 @@ Last-Update: 2017-11-22
#ifdef __cplusplus #ifdef __cplusplus
extern "C" { extern "C" {
#endif #endif
@@ -548,6 +581,14 @@ extern void xtables_lmap_free(struct xta @@ -549,6 +582,14 @@ extern void xtables_lmap_free(struct xta
extern int xtables_lmap_name2id(const struct xtables_lmap *, const char *); extern int xtables_lmap_name2id(const struct xtables_lmap *, const char *);
extern const char *xtables_lmap_id2name(const struct xtables_lmap *, int); extern const char *xtables_lmap_id2name(const struct xtables_lmap *, int);

@ -1,6 +1,6 @@
--- a/configure --- a/configure
+++ b/configure +++ b/configure
@@ -254,7 +254,7 @@ check_selinux() @@ -255,7 +255,7 @@ check_selinux()
check_mnl() check_mnl()
{ {

@ -41,7 +41,7 @@
+#endif +#endif
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n" " OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n" " -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
" -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n" " -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
@@ -72,32 +78,44 @@ static const struct cmd { @@ -72,32 +78,44 @@ static const struct cmd {
int (*func)(int argc, char **argv); int (*func)(int argc, char **argv);
} cmds[] = { } cmds[] = {
@ -87,24 +87,6 @@
{ "vrf", do_ipvrf}, { "vrf", do_ipvrf},
{ "sr", do_seg6 }, { "sr", do_seg6 },
{ "help", do_help }, { "help", do_help },
--- a/lib/utils.c
+++ b/lib/utils.c
@@ -1000,6 +1000,7 @@ const char *rt_addr_n2a_r(int af, int le
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
+#ifndef IPROUTE2_TINY
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
@@ -1009,6 +1010,7 @@ const char *rt_addr_n2a_r(int af, int le
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
+#endif
case AF_PACKET:
return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
case AF_BRIDGE:
--- a/lib/Makefile --- a/lib/Makefile
+++ b/lib/Makefile +++ b/lib/Makefile
@@ -3,6 +3,10 @@ include ../config.mk @@ -3,6 +3,10 @@ include ../config.mk

Loading…
Cancel
Save