update gdb to 7.2

This patch updates the toolchain gdb from 6.8 to 7.2

Signed-off-by: Steve Brown <sbrown@cortland.com>

SVN-Revision: 25585
v19.07.3_mercusys_ac12_duma
Florian Fainelli 14 years ago
parent b7f8e1276d
commit 237d0ec935

@ -7,10 +7,10 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=gdb PKG_NAME:=gdb
PKG_VERSION:=6.8 PKG_VERSION:=7.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a PKG_MD5SUM:=64260e6c56979ee750a01055f16091a5
PKG_SOURCE_URL:=@GNU/gdb PKG_SOURCE_URL:=@GNU/gdb
include $(INCLUDE_DIR)/toolchain-build.mk include $(INCLUDE_DIR)/toolchain-build.mk

@ -1,26 +1,17 @@
--- a/gdb/gdbserver/configure Index: openwrt/dl/gdb-7.2/gdb/configure
+++ b/gdb/gdbserver/configure ===================================================================
@@ -1239,7 +1239,7 @@ --- gdb-7.2/gdb/configure
ac_cache_corrupted=: ;; +++ gdb-7.2/gdb/configure
,);; @@ -988,7 +988,7 @@ CPP
*) YACC
- if test "x$ac_old_val" != "x$ac_new_val"; then YFLAGS
+ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then XMKMF'
{ echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5 -ac_subdirs_all='doc testsuite
echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;} +ac_subdirs_all='doc
{ echo "$as_me:$LINENO: former value: $ac_old_val" >&5 gdbtk
--- a/gdb/configure multi-ice
+++ b/gdb/configure gdbserver'
@@ -272,7 +272,7 @@ @@ -7880,7 +7880,7 @@ fi
PACKAGE_BUGREPORT=
ac_unique_file="main.c"
-ac_subdirs_all="$ac_subdirs_all doc testsuite"
+ac_subdirs_all="$ac_subdirs_all doc"
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
@@ -3077,7 +3077,7 @@
@ -28,4 +19,17 @@
+subdirs="$subdirs doc" +subdirs="$subdirs doc"
# Provide defaults for some variables set by the per-host and per-target # Check whether to support alternative target configurations
Index: openwrt/dl/gdb-7.2/gdb/gdbserver/configure
===================================================================
--- gdb-7.2/gdb/gdbserver/configure
+++ gdb-7.2/gdb/gdbserver/configure
@@ -2151,7 +2151,7 @@ $as_echo "$as_me: error: \`$ac_var' was
ac_cache_corrupted=: ;;
,);;
*)
- if test "x$ac_old_val" != "x$ac_new_val"; then
+ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
# differences in whitespace do not lead to failure.
ac_old_val_w=`echo x $ac_old_val`
ac_new_val_w=`echo x $ac_new_val`

Loading…
Cancel
Save