iproute2: update version to 3.15.0, refresh patches, add maintainer

Signed-off-by: Russell Senior <russell@personaltelco.net>

SVN-Revision: 41227
v19.07.3_mercusys_ac12_duma
Steven Barth 10 years ago
parent c8b4058bf3
commit 1e989206f4

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006-2013 OpenWrt.org # Copyright (C) 2006-2014 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2 PKG_NAME:=iproute2
PKG_VERSION:=3.11.0 PKG_VERSION:=3.15.0
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/ PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
PKG_MD5SUM:=d7ffb27bc9f0d80577b1f3fb9d1a7689 PKG_MD5SUM:=5b1711c9d16071959052e369a2682d77
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@ -24,8 +24,9 @@ define Package/iproute2/Default
TITLE:=Routing control utility ($(2)) TITLE:=Routing control utility ($(2))
SECTION:=net SECTION:=net
CATEGORY:=Network CATEGORY:=Network
URL:=http://linux-net.osdl.org/index.php/Iproute2 URL:=http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
SUBMENU:=Routing and Redirection SUBMENU:=Routing and Redirection
MAINTAINER:=Russell Senior <russell@personaltelco.net>
DEPENDS:= +libnl-tiny DEPENDS:= +libnl-tiny
VARIANT:=$(1) VARIANT:=$(1)
endef endef

@ -1,6 +1,6 @@
--- a/ip/ipxfrm.c --- a/ip/ipxfrm.c
+++ b/ip/ipxfrm.c +++ b/ip/ipxfrm.c
@@ -470,7 +470,6 @@ void xfrm_selector_print(struct xfrm_sel @@ -469,7 +469,6 @@ void xfrm_selector_print(struct xfrm_sel
switch (sel->proto) { switch (sel->proto) {
case IPPROTO_TCP: case IPPROTO_TCP:
case IPPROTO_UDP: case IPPROTO_UDP:
@ -8,7 +8,7 @@
case IPPROTO_DCCP: case IPPROTO_DCCP:
default: /* XXX */ default: /* XXX */
if (sel->sport_mask) if (sel->sport_mask)
@@ -1283,7 +1282,6 @@ static int xfrm_selector_upspec_parse(st @@ -1282,7 +1281,6 @@ static int xfrm_selector_upspec_parse(st
switch (sel->proto) { switch (sel->proto) {
case IPPROTO_TCP: case IPPROTO_TCP:
case IPPROTO_UDP: case IPPROTO_UDP:

@ -7,5 +7,5 @@
-CCOPTS = -O2 -CCOPTS = -O2
+CCOPTS = -O2 $(EXTRA_CCOPTS) +CCOPTS = -O2 $(EXTRA_CCOPTS)
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
WFLAGS += -Wmissing-declarations -Wold-style-definition WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2

@ -10,7 +10,7 @@
TCMODULES += q_tbf.o TCMODULES += q_tbf.o
--- a/include/linux/pkt_sched.h --- a/include/linux/pkt_sched.h
+++ b/include/linux/pkt_sched.h +++ b/include/linux/pkt_sched.h
@@ -222,6 +222,33 @@ struct tc_sfq_xstats { @@ -226,6 +226,33 @@ struct tc_sfq_xstats {
__s32 allot; __s32 allot;
}; };

@ -1,13 +1,13 @@
--- a/tc/Makefile --- a/tc/Makefile
+++ b/tc/Makefile +++ b/tc/Makefile
@@ -38,6 +38,7 @@ TCMODULES += m_mirred.o @@ -39,6 +39,7 @@ TCMODULES += m_mirred.o
TCMODULES += m_nat.o TCMODULES += m_nat.o
TCMODULES += m_pedit.o TCMODULES += m_pedit.o
TCMODULES += m_skbedit.o TCMODULES += m_skbedit.o
+TCMODULES += m_connmark.o +TCMODULES += m_connmark.o
TCMODULES += m_csum.o TCMODULES += m_csum.o
TCMODULES += m_simple.o
TCMODULES += p_ip.o TCMODULES += p_ip.o
TCMODULES += p_icmp.o
--- /dev/null --- /dev/null
+++ b/tc/m_connmark.c +++ b/tc/m_connmark.c
@@ -0,0 +1,74 @@ @@ -0,0 +1,74 @@

@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ) ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon TARGETS=ip rtmon
@@ -43,7 +50,7 @@ else @@ -42,7 +49,7 @@ else
ip: static-syms.o ip: static-syms.o
static-syms.o: static-syms.h static-syms.o: static-syms.h

Loading…
Cancel
Save