You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/obsolete-buildroot/sources/netsnmp.patch

33 lines
1.2 KiB
Diff

diff -urN net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c net-snmp-5.1/agent/mibgroup/host/hr_system.c
--- net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c 2003-02-28 22:35:13.000000000 -0600
+++ net-snmp-5.1/agent/mibgroup/host/hr_system.c 2004-03-31 22:06:05.000000000 -0600
@@ -286,7 +286,11 @@
current user */
if (kill(utmp_p->ut_pid, 0) == -1 && errno == ESRCH) {
utmp_p->ut_type = DEAD_PROCESS;
+#if HAVE_UTMPX_H
pututxline(utmp_p);
+#else
+ pututline(utmp_p);
+#endif
continue;
}
++total;
diff -urN net-snmp-5.1-dist/configure.in net-snmp-5.1/configure.in
--- net-snmp-5.1-dist/configure.in 2004-03-31 21:59:14.000000000 -0600
+++ net-snmp-5.1/configure.in 2004-03-31 22:06:05.000000000 -0600
@@ -1865,13 +1865,8 @@
if test $cross_compiling = yes; then
if test $with_endianness = "big"; then
AC_DEFINE(WORDS_BIGENDIAN)
- elif test -z $with_endianness; then
- AC_MSG_ERROR([You are cross-compiling, but you have not specified the target's endianness])
fi
else
- if test $with_endianness; then
- AC_MSG_ERROR([Endianness has been specified, but you are not cross-compiling.])
- fi
AC_C_BIGENDIAN
fi