You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_upd...

33 lines
934 B
Diff

From ea71d637a9d8606624056fad67d050face9fc03c Mon Sep 17 00:00:00 2001
From: Kurt Mahan <kmahan@freescale.com>
Date: Fri, 15 Feb 2008 15:32:35 -0700
Subject: [PATCH] Update to use KBUILD_ for CFLAGS and AFLAGS.
LTIBName: mcfv4e-kbuild-flags-update
Signed-off-by: Kurt Mahan <kmahan@freescale.com>
---
arch/m68k/Makefile | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
--- a/arch/m68k/Makefile
+++ b/arch/m68k/Makefile
@@ -33,6 +33,7 @@ LDFLAGS_vmlinux = -N
endif
ifdef CONFIG_COLDFIRE
+# OBJCOPYFLAGS := -R .note -R .note.gnu.build-id -R .comment -S
# LDFLAGS_vmlinux = --verbose
endif
@@ -59,8 +60,8 @@ endif
endif
ifdef CONFIG_M54455
-CFLAGS := $(CFLAGS) -march=isac -mcpu=54455 -msoft-float -g
-AFLAGS := $(AFLAGS) -march=isac -mcpu=54455 -msoft-float
+KBUILD_CFLAGS += -march=isac -mcpu=54455 -msoft-float -g
+KBUILD_AFLAGS += -march=isac -mcpu=54455 -msoft-float
endif
ifdef CONFIG_KGDB