You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/at91/patches/200-experimenta_adc_driver....

29 lines
1.1 KiB
Diff

Index: linux-2.6.38/drivers/misc/Kconfig
===================================================================
--- linux-2.6.38.orig/drivers/misc/Kconfig 2011-03-15 02:20:32.000000000 +0100
+++ linux-2.6.38/drivers/misc/Kconfig 2011-03-20 22:54:33.114794033 +0100
@@ -104,6 +104,10 @@
TC can be used for other purposes, such as PWM generation and
interval timing.
+config AT91_ADC
+ tristate "AT91 ADC converter"
+ depends on ARCH_AT91 && SYSFS
+
config IBM_ASM
tristate "Device driver for IBM RSA service processor"
depends on X86 && PCI && INPUT && EXPERIMENTAL
Index: linux-2.6.38/drivers/misc/Makefile
===================================================================
--- linux-2.6.38.orig/drivers/misc/Makefile 2011-03-15 02:20:32.000000000 +0100
+++ linux-2.6.38/drivers/misc/Makefile 2011-03-20 22:55:18.000000000 +0100
@@ -9,6 +9,7 @@
obj-$(CONFIG_ATMEL_PWM) += atmel_pwm.o
obj-$(CONFIG_ATMEL_SSC) += atmel-ssc.o
obj-$(CONFIG_ATMEL_TCLIB) += atmel_tclib.o
+obj-$(CONFIG_AT91_ADC) += at91-adc.o
obj-$(CONFIG_BMP085) += bmp085.o
obj-$(CONFIG_ICS932S401) += ics932s401.o
obj-$(CONFIG_LKDTM) += lkdtm.o