You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch

14 lines
516 B
Diff

diff -urN linux-2.6.19.old/Makefile linux-2.6.19.dev/Makefile
--- linux-2.6.19.old/Makefile 2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.dev/Makefile 2006-12-14 03:13:23.000000000 +0100
@@ -513,6 +513,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)