You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/hotplug2/patches/110-static_worker.patch

21 lines
309 B
Diff

--- a/common.mak
+++ b/common.mak
@@ -1,7 +1,7 @@
# vim:set sw=8 nosta:
COPTS=-Os -Wall -g
-LDFLAGS=-g -ldl
+LDFLAGS=-g
CFLAGS=$(COPTS)
FPIC=-fPIC
--- a/Makefile
+++ b/Makefile
@@ -40,5 +40,6 @@ ifdef STATIC_WORKER
CFLAGS += -DSTATIC_WORKER=1
else
CFLAGS += $(FPIC)
+ LDFLAGS += -ldl
endif