You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/toolchain/binutils/patches/2.17/100-uclibc-conf.patch

160 lines
5.1 KiB
Diff

Index: binutils-2.17/bfd/configure
===================================================================
--- binutils-2.17.orig/bfd/configure 2007-06-28 09:19:34.892931920 +0200
+++ binutils-2.17/bfd/configure 2007-06-28 09:19:35.023912008 +0200
@@ -3576,7 +3576,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
lt_cv_deplibs_check_method=pass_all
;;
Index: binutils-2.17/binutils/configure
===================================================================
--- binutils-2.17.orig/binutils/configure 2007-06-28 09:19:34.898931008 +0200
+++ binutils-2.17/binutils/configure 2007-06-28 09:19:35.028911248 +0200
@@ -3411,7 +3411,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
lt_cv_deplibs_check_method=pass_all
;;
Index: binutils-2.17/configure
===================================================================
--- binutils-2.17.orig/configure 2007-06-28 09:19:34.903930248 +0200
+++ binutils-2.17/configure 2007-06-28 09:19:35.030910944 +0200
@@ -1276,7 +1276,7 @@
am33_2.0-*-linux*)
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
;;
- sh-*-linux*)
+ sh*-*-linux*)
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
;;
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
@@ -1584,7 +1584,7 @@
romp-*-*)
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
;;
- sh-*-* | sh64-*-*)
+ sh*-*-* | sh64-*-*)
case "${host}" in
i[3456789]86-*-vsta) ;; # don't add gprof back in
i[3456789]86-*-go32*) ;; # don't add gprof back in
Index: binutils-2.17/configure.in
===================================================================
--- binutils-2.17.orig/configure.in 2007-06-28 09:19:34.909929336 +0200
+++ binutils-2.17/configure.in 2007-06-28 09:19:35.031910792 +0200
@@ -468,7 +468,7 @@
am33_2.0-*-linux*)
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
;;
- sh-*-linux*)
+ sh*-*-linux*)
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
;;
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
@@ -776,7 +776,7 @@
romp-*-*)
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
;;
- sh-*-* | sh64-*-*)
+ sh*-*-* | sh64-*-*)
case "${host}" in
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
Index: binutils-2.17/gas/configure
===================================================================
--- binutils-2.17.orig/gas/configure 2007-06-28 09:19:34.915928424 +0200
+++ binutils-2.17/gas/configure 2007-06-28 09:19:35.035910184 +0200
@@ -3411,7 +3411,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
lt_cv_deplibs_check_method=pass_all
;;
Index: binutils-2.17/gprof/configure
===================================================================
--- binutils-2.17.orig/gprof/configure 2007-06-28 09:19:34.921927512 +0200
+++ binutils-2.17/gprof/configure 2007-06-28 09:19:35.042909120 +0200
@@ -3414,6 +3414,11 @@
lt_cv_deplibs_check_method=pass_all
;;
+linux-uclibc*)
+ lt_cv_deplibs_check_method=pass_all
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
+ ;;
+
netbsd* | knetbsd*-gnu)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
Index: binutils-2.17/ld/configure
===================================================================
--- binutils-2.17.orig/ld/configure 2007-06-28 09:19:34.927926600 +0200
+++ binutils-2.17/ld/configure 2007-06-28 09:19:35.046908512 +0200
@@ -3413,7 +3413,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
lt_cv_deplibs_check_method=pass_all
;;
Index: binutils-2.17/libtool.m4
===================================================================
--- binutils-2.17.orig/libtool.m4 2007-06-28 09:19:34.933925688 +0200
+++ binutils-2.17/libtool.m4 2007-06-28 09:19:35.047908360 +0200
@@ -739,7 +739,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
lt_cv_deplibs_check_method=pass_all
;;
Index: binutils-2.17/ltconfig
===================================================================
--- binutils-2.17.orig/ltconfig 2007-06-28 09:19:34.939924776 +0200
+++ binutils-2.17/ltconfig 2007-06-28 09:19:35.048908208 +0200
@@ -602,6 +602,7 @@
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
case $host_os in
+linux-uclibc*) ;;
linux-gnu*) ;;
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
esac
@@ -1247,7 +1248,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
version_type=linux
need_lib_prefix=no
need_version=no
Index: binutils-2.17/opcodes/configure
===================================================================
--- binutils-2.17.orig/opcodes/configure 2007-06-28 09:19:34.946923712 +0200
+++ binutils-2.17/opcodes/configure 2007-06-28 09:19:35.051907752 +0200
@@ -3579,7 +3579,7 @@
;;
# This must be Linux ELF.
-linux-gnu*)
+linux-gnu*|linux-uclibc*)
lt_cv_deplibs_check_method=pass_all
;;