You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/ppp/patches/010-use_target_for_configur...

21 lines
498 B
Diff

Use values exported from $(TOPDIR)/rules.mk for determining
the target system instead of the host configuration
--- ppp-2.4.3/configure.orig Sat Nov 6 11:36:32 2004
+++ ppp-2.4.3/configure Sun Jun 18 23:40:46 2006
@@ -8,9 +8,9 @@ SYSCONF=/etc
# if [ -d /NextApps ]; then
# system="NeXTStep"
# else
- system=`uname -s`
- release=`uname -r`
- arch=`uname -m`
+ system=${UNAME_S:-`uname -s`}
+ release=${UNAME_R:-`uname -r`}
+ arch=${UNAME_M:-`uname -m`}
# fi
state="unknown"