You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/generic-2.6/patches/010-disable_old_squashfs_co...

24 lines
803 B
Diff

Index: linux-2.6.21.7/fs/squashfs/Makefile
===================================================================
--- linux-2.6.21.7.orig/fs/squashfs/Makefile
+++ linux-2.6.21.7/fs/squashfs/Makefile
@@ -4,4 +4,3 @@
obj-$(CONFIG_SQUASHFS) += squashfs.o
squashfs-y += inode.o
-squashfs-y += squashfs2_0.o
Index: linux-2.6.21.7/fs/squashfs/squashfs.h
===================================================================
--- linux-2.6.21.7.orig/fs/squashfs/squashfs.h
+++ linux-2.6.21.7/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)