You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/madwifi/patches/476-3.0_detection_fix.patch

26 lines
714 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -155,13 +155,15 @@ unload:
configcheck:
@echo -n "Checking kernel configuration... "
- @# check version of kernel
- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
- echo "FAILED"; \
- echo "Only kernel versions 2.4.x and above are supported."; \
- echo "You have $(KERNELRELEASE)."; \
- exit 1; \
- }
+ @# check kernel version
+ @case $(KERNELRELEASE) in \
+ 2.[456].*) ;; \
+ [3-9].*) ;; \
+ *) echo "FAILED"; \
+ echo "Only kernel versions 2.4.x and above are supported."; \
+ echo "You have $(KERNELRELEASE)."; \
+ exit 1 ;; \
+ esac
@# check kernel configuration
@if [ -z "$(CONFIG_SYSCTL)" ]; then \