You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/bcm27xx/patches-5.4/950-0721-dtoverlays-Add-IMX...

157 lines
3.7 KiB
Diff

From 738defbb964c5d2a34b08c24ac0e7fd4afb16173 Mon Sep 17 00:00:00 2001
From: Naushir Patuck <naush@raspberrypi.com>
Date: Thu, 7 May 2020 15:50:04 +0100
Subject: [PATCH] dtoverlays: Add IMX477 sensor overlay
Add an overlay for the Sony IMX477 CMOS sensor device.
Also update overlay README and Makefile.
Signed-off-by: Naushir Patuck <naush@raspberrypi.com>
---
arch/arm/boot/dts/overlays/Makefile | 1 +
arch/arm/boot/dts/overlays/README | 8 ++
arch/arm/boot/dts/overlays/imx477-overlay.dts | 110 ++++++++++++++++++
3 files changed, 119 insertions(+)
create mode 100644 arch/arm/boot/dts/overlays/imx477-overlay.dts
--- a/arch/arm/boot/dts/overlays/Makefile
+++ b/arch/arm/boot/dts/overlays/Makefile
@@ -85,6 +85,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
i2s-gpio28-31.dtbo \
ilitek251x.dtbo \
imx219.dtbo \
+ imx477.dtbo \
iqaudio-codec.dtbo \
iqaudio-dac.dtbo \
iqaudio-dacplus.dtbo \
--- a/arch/arm/boot/dts/overlays/README
+++ b/arch/arm/boot/dts/overlays/README
@@ -1390,6 +1390,14 @@ Load: dtoverlay=imx219
Params: <None>
+Name: imx477
+Info: Sony IMX477 camera module.
+ Uses Unicam 1, which is the standard camera connector on most Pi
+ variants.
+Load: dtoverlay=imx477
+Params: <None>
+
+
Name: iqaudio-codec
Info: Configures the IQaudio Codec audio card
Load: dtoverlay=iqaudio-codec
--- /dev/null
+++ b/arch/arm/boot/dts/overlays/imx477-overlay.dts
@@ -0,0 +1,110 @@
+// SPDX-License-Identifier: GPL-2.0-only
+// Definitions for IMX477 camera module on VC I2C bus
+/dts-v1/;
+/plugin/;
+
+#include <dt-bindings/gpio/gpio.h>
+
+/{
+ compatible = "brcm,bcm2835";
+
+ fragment@0 {
+ target = <&i2c_csi_dsi>;
+ __overlay__ {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ imx477: imx477@1a {
+ compatible = "sony,imx477";
+ reg = <0x1a>;
+ status = "okay";
+
+ clocks = <&imx477_clk>;
+ clock-names = "xclk";
+
+ VANA-supply = <&imx477_vana>; /* 2.8v */
+ VDIG-supply = <&imx477_vdig>; /* 1.05v */
+ VDDL-supply = <&imx477_vddl>; /* 1.8v */
+
+ port {
+ imx477_0: endpoint {
+ remote-endpoint = <&csi1_ep>;
+ clock-lanes = <0>;
+ data-lanes = <1 2>;
+ clock-noncontinuous;
+ link-frequencies =
+ /bits/ 64 <450000000>;
+ };
+ };
+ };
+ };
+ };
+
+ fragment@1 {
+ target = <&csi1>;
+ __overlay__ {
+ status = "okay";
+
+ port {
+ csi1_ep: endpoint {
+ remote-endpoint = <&imx477_0>;
+ };
+ };
+ };
+ };
+
+ fragment@2 {
+ target = <&i2c0if>;
+ __overlay__ {
+ status = "okay";
+ };
+ };
+
+ fragment@3 {
+ target-path="/";
+ __overlay__ {
+ imx477_vana: fixedregulator@0 {
+ compatible = "regulator-fixed";
+ regulator-name = "imx477_vana";
+ regulator-min-microvolt = <2800000>;
+ regulator-max-microvolt = <2800000>;
+ gpio = <&gpio 41 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ startup-delay-us = <300000>;
+ };
+ imx477_vdig: fixedregulator@1 {
+ compatible = "regulator-fixed";
+ regulator-name = "imx477_vdig";
+ regulator-min-microvolt = <1050000>;
+ regulator-max-microvolt = <1050000>;
+ };
+ imx477_vddl: fixedregulator@2 {
+ compatible = "regulator-fixed";
+ regulator-name = "imx477_vddl";
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <1800000>;
+ };
+ imx477_clk: camera-clk {
+ compatible = "fixed-clock";
+ #clock-cells = <0>;
+ clock-frequency = <24000000>;
+ };
+ };
+ };
+
+ fragment@4 {
+ target = <&i2c0mux>;
+ __overlay__ {
+ status = "okay";
+ };
+ };
+
+ fragment@5 {
+ target-path="/__overrides__";
+ __overlay__ {
+ cam0-pwdn-ctrl = <&imx477_vana>,"gpio:0";
+ cam0-pwdn = <&imx477_vana>,"gpio:4";
+ };
+ };
+};