You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/tools/mkimage/patches/040-include_order.patch

15 lines
498 B
Diff

--- a/tools/Makefile
+++ b/tools/Makefile
@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
# Use native tools and options
# Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
#
-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
+HOSTCPPFLAGS = -I $(SRCTREE)/include \
-idirafter $(OBJTREE)/include2 \
- -idirafter $(OBJTREE)/include \
+ -I $(OBJTREE)/include \
-I $(SRCTREE)/lib/libfdt \
-I $(SRCTREE)/tools \
-DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \