You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch

26 lines
725 B
Diff

--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -96,6 +96,12 @@ config MSP_FLASH_MAP_LIMIT
default "0x02000000"
depends on MSP_FLASH_MAP_LIMIT_32M
+config MTD_ADM8668_NOR
+ tristate "ADM8668 NOR mapping"
+ depends on ADM8668 && MTD_CFI
+ help
+ mapping driver for ADM8668 NOR
+
config MTD_SUN_UFLASH
tristate "Sun Microsystems userflash support"
depends on SPARC && MTD_CFI && PCI
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += map_funcs.o
endif
# Chip mappings
+obj-$(CONFIG_MTD_ADM8668_NOR) += adm8668.o
obj-$(CONFIG_MTD_CDB89712) += cdb89712.o
obj-$(CONFIG_MTD_CFI_FLAGADM) += cfi_flagadm.o
obj-$(CONFIG_MTD_DC21285) += dc21285.o