You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/wireless-tools/patches/01-debian.patch

36 lines
1009 B
Diff

--- wireless-tools-27.orig/iwlib.c
+++ wireless-tools-27/iwlib.c
@@ -622,6 +622,7 @@
{
struct iwreq wrq;
+ memset((char *) &wrq, 0, sizeof(struct iwreq));
memset((char *) info, 0, sizeof(struct wireless_config));
/* Get wireless name */
--- wireless-tools-27.orig/Makefile
+++ wireless-tools-27/Makefile
@@ -64,8 +64,8 @@
# Install directories
INSTALL_DIR= $(PREFIX)/sbin/
INSTALL_LIB= $(PREFIX)/lib/
-INSTALL_INC= $(PREFIX)/include/
-INSTALL_MAN= $(PREFIX)/man/
+INSTALL_INC= $(PREFIX)/usr/include/
+INSTALL_MAN= $(PREFIX)/usr/share/man/
# Various commands
RM = rm -f
@@ -81,9 +81,9 @@
endif
# Other flags
-CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
+#CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
-Wpointer-arith -Wcast-qual -Winline -I.
-#CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
+CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
DEPFLAGS=-MMD
XCFLAGS=$(CFLAGS) $(DEPFLAGS) $(WARN) $(HEADERS) $(WELIB_FLAG)
PICFLAG=-fPIC