You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/network/utils/comgt/patches/001-compile_fix.patch

24 lines
408 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -32,6 +32,7 @@ SCRIPTPATH = /etc/comgt/
SCRIPTSRC = ./scripts/
BIN = $(CPROG)
MANP = comgt.1 sigmon.1
+CC = cc
CFLAGS = -c
LDFLAGS =
@@ -70,10 +71,5 @@ clean:
-rm *~
-rm $(SCRIPTSRC)*~
-
-comgt: comgt.o
- cc comgt.o $(LDFLAGS) -o comgt
-
-comgt.o: comgt.c comgt.h
- cc comgt.c $(CFLAGS)
-
+comgt: comgt.c comgt.h
+ $(CC) $(CFLAGS) -o comgt $< $(LDFLAGS)