You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/openwrt/tools/squashfs/patches/100-lzma.patch

26 lines
877 B
Diff

diff -Nur squashfs3.0/squashfs-tools/Makefile squashfs3.0-owrt/squashfs-tools/Makefile
--- squashfs3.0/squashfs-tools/Makefile 2006-03-15 22:36:20.000000000 +0100
+++ squashfs3.0-owrt/squashfs-tools/Makefile 2006-03-21 11:14:08.000000000 +0100
@@ -1,4 +1,5 @@
INCLUDEDIR = .
+#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
@@ -7,6 +8,9 @@
mksquashfs: mksquashfs.o read_fs.o sort.o
$(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
+mksquashfs-lzma: mksquashfs.o read_fs.o sort.o
+ $(CXX) mksquashfs.o read_fs.o sort.o -L$(LZMAPATH) -llzma -o $@
+
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
@@ -17,3 +21,5 @@
$(CC) unsquashfs.o -lz -o $@
unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
+
+clean: