You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/generic/pending-4.14/206-mips-disable-vdso.patch

24 lines
795 B
Diff

From: Felix Fietkau <nbd@nbd.name>
Subject: kernel: disable MIPS VDSO by default until the cache issues have been resolved
lede-commit: 1185e645a773c86aa88cf04d0e2911dc62eb43f5
Signed-off-by: Felix Fietkau <nbd@nbd.name>
---
arch/mips/vdso/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/arch/mips/vdso/Makefile
+++ b/arch/mips/vdso/Makefile
@@ -30,9 +30,9 @@ aflags-vdso := $(ccflags-vdso) \
ifndef CONFIG_CPU_MIPSR6
ifeq ($(call ld-ifversion, -lt, 225000000, y),y)
$(warning MIPS VDSO requires binutils >= 2.25)
- obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
- ccflags-vdso += -DDISABLE_MIPS_VDSO
endif
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
endif
# VDSO linker flags.