You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/tools/mkimage/patches/100-freebsd-compat.patch

15 lines
408 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -634,7 +634,10 @@ UBOOTINCLUDE := \
-I$(srctree)/arch/$(ARCH)/include \
-include $(srctree)/include/linux/kconfig.h
-NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ifneq ($(shell uname),FreeBSD)
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+endif
+
CHECKFLAGS += $(NOSTDINC_FLAGS)
# FIX ME