You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/brcm2708/patches-4.14/950-0236-Removing-broken-Ra...

340 lines
10 KiB
Diff

From 50e9c65f5062bba726f94374127ea89f78102aa3 Mon Sep 17 00:00:00 2001
From: Phil Elwell <phil@raspberrypi.org>
Date: Wed, 28 Feb 2018 22:28:14 +0000
Subject: [PATCH 236/454] Removing (broken) RaspiDac3 support...
...at the request of the author.
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
---
arch/arm/boot/dts/overlays/Makefile | 1 -
arch/arm/boot/dts/overlays/README | 6 -
.../boot/dts/overlays/raspidac3-overlay.dts | 49 -----
arch/arm/configs/bcm2709_defconfig | 1 -
arch/arm/configs/bcmrpi_defconfig | 1 -
arch/arm64/configs/bcmrpi3_defconfig | 1 -
sound/soc/bcm/Kconfig | 8 -
sound/soc/bcm/Makefile | 2 -
sound/soc/bcm/raspidac3.c | 172 ------------------
9 files changed, 241 deletions(-)
delete mode 100644 arch/arm/boot/dts/overlays/raspidac3-overlay.dts
delete mode 100644 sound/soc/bcm/raspidac3.c
--- a/arch/arm/boot/dts/overlays/Makefile
+++ b/arch/arm/boot/dts/overlays/Makefile
@@ -89,7 +89,6 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
pwm-2chan.dtbo \
pwm-ir-tx.dtbo \
qca7000.dtbo \
- raspidac3.dtbo \
rotary-encoder.dtbo \
rpi-backlight.dtbo \
rpi-cirrus-wm5102.dtbo \
--- a/arch/arm/boot/dts/overlays/README
+++ b/arch/arm/boot/dts/overlays/README
@@ -1350,12 +1350,6 @@ Params: int_pin GPIO pin
speed SPI bus speed (default 12 MHz)
-Name: raspidac3
-Info: Configures the RaspiDAV Rev.3x audio card
-Load: dtoverlay=raspidac3
-Params: <None>
-
-
Name: rotary-encoder
Info: Overlay for GPIO connected rotary encoder.
Load: dtoverlay=rotary-encoder,<param>=<val>
--- a/arch/arm/boot/dts/overlays/raspidac3-overlay.dts
+++ /dev/null
@@ -1,49 +0,0 @@
-// Definitions for RaspiDACv3
-/dts-v1/;
-/plugin/;
-
-/ {
- compatible = "brcm,bcm2708";
-
- fragment@0 {
- target = <&i2s>;
- __overlay__ {
- status = "okay";
- };
- };
-
- fragment@1 {
- target = <&i2c1>;
- __overlay__ {
- #address-cells = <1>;
- #size-cells = <0>;
- status = "okay";
-
- pcm5122@4c {
- #sound-dai-cells = <0>;
- compatible = "ti,pcm5122";
- reg = <0x4c>;
- AVDD-supply = <&vdd_3v3_reg>;
- DVDD-supply = <&vdd_3v3_reg>;
- CPVDD-supply = <&vdd_3v3_reg>;
- status = "okay";
- };
-
- tpa6130a2: tpa6130a2@60 {
- compatible = "ti,tpa6130a2";
- reg = <0x60>;
- Vdd-supply = <&vdd_3v3_reg>;
- status = "okay";
- };
- };
- };
-
- fragment@2 {
- target = <&sound>;
- __overlay__ {
- compatible = "jg,raspidacv3";
- i2s-controller = <&i2s>;
- status = "okay";
- };
- };
-};
--- a/arch/arm/configs/bcm2709_defconfig
+++ b/arch/arm/configs/bcm2709_defconfig
@@ -879,7 +879,6 @@ CONFIG_SND_BCM2708_SOC_JUSTBOOM_DAC=m
CONFIG_SND_BCM2708_SOC_JUSTBOOM_DIGI=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DIGI=m
-CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
CONFIG_SND_AUDIOINJECTOR_OCTO_SOUNDCARD=m
--- a/arch/arm/configs/bcmrpi_defconfig
+++ b/arch/arm/configs/bcmrpi_defconfig
@@ -872,7 +872,6 @@ CONFIG_SND_BCM2708_SOC_JUSTBOOM_DAC=m
CONFIG_SND_BCM2708_SOC_JUSTBOOM_DIGI=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DIGI=m
-CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
CONFIG_SND_AUDIOINJECTOR_OCTO_SOUNDCARD=m
--- a/arch/arm64/configs/bcmrpi3_defconfig
+++ b/arch/arm64/configs/bcmrpi3_defconfig
@@ -861,7 +861,6 @@ CONFIG_SND_BCM2708_SOC_JUSTBOOM_DAC=m
CONFIG_SND_BCM2708_SOC_JUSTBOOM_DIGI=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DIGI=m
-CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
CONFIG_SND_DIGIDAC1_SOUNDCARD=m
--- a/sound/soc/bcm/Kconfig
+++ b/sound/soc/bcm/Kconfig
@@ -104,14 +104,6 @@ config SND_BCM2708_SOC_IQAUDIO_DIGI
help
Say Y or M if you want to add support for IQAudIO Digital IO board.
-config SND_BCM2708_SOC_RASPIDAC3
- tristate "Support for RaspiDAC Rev.3x"
- depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
- select SND_SOC_PCM512x_I2C
- select SND_SOC_TPA6130A2
- help
- Say Y or M if you want to add support for RaspiDAC Rev.3x.
-
config SND_BCM2708_SOC_ADAU1977_ADC
tristate "Support for ADAU1977 ADC"
depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
--- a/sound/soc/bcm/Makefile
+++ b/sound/soc/bcm/Makefile
@@ -25,7 +25,6 @@ snd-soc-rpi-dac-objs := rpi-dac.o
snd-soc-rpi-proto-objs := rpi-proto.o
snd-soc-iqaudio-dac-objs := iqaudio-dac.o
snd-soc-iqaudio-digi-objs := iqaudio_digi.o
-snd-soc-raspidac3-objs := raspidac3.o
snd-soc-audioinjector-pi-soundcard-objs := audioinjector-pi-soundcard.o
snd-soc-audioinjector-octo-soundcard-objs := audioinjector-octo-soundcard.o
snd-soc-digidac1-soundcard-objs := digidac1-soundcard.o
@@ -52,7 +51,6 @@ obj-$(CONFIG_SND_BCM2708_SOC_RPI_DAC) +=
obj-$(CONFIG_SND_BCM2708_SOC_RPI_PROTO) += snd-soc-rpi-proto.o
obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) += snd-soc-iqaudio-dac.o
obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DIGI) += snd-soc-iqaudio-digi.o
-obj-$(CONFIG_SND_BCM2708_SOC_RASPIDAC3) += snd-soc-raspidac3.o
obj-$(CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD) += snd-soc-audioinjector-pi-soundcard.o
obj-$(CONFIG_SND_AUDIOINJECTOR_OCTO_SOUNDCARD) += snd-soc-audioinjector-octo-soundcard.o
obj-$(CONFIG_SND_DIGIDAC1_SOUNDCARD) += snd-soc-digidac1-soundcard.o
--- a/sound/soc/bcm/raspidac3.c
+++ /dev/null
@@ -1,172 +0,0 @@
-/*
- * ASoC Driver for RaspiDAC v3
- *
- * Author: Jan Grulich <jan@grulich.eu>
- * Copyright 2015
- * based on code by Daniel Matuschek <daniel@hifiberry.com>
- * based on code by Florian Meier <florian.meier@koalo.de>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License
- * version 2 as published by the Free Software Foundation.
- *
- * This program is distributed in the hope that it will be useful, but
- * WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- * General Public License for more details.
- */
-
-#include <linux/module.h>
-#include <linux/platform_device.h>
-
-#include <sound/core.h>
-#include <sound/pcm.h>
-#include <sound/pcm_params.h>
-#include <sound/soc.h>
-#include <sound/jack.h>
-#include <sound/soc-dapm.h>
-
-#include "../codecs/pcm512x.h"
-#include "../codecs/tpa6130a2.h"
-
-/* sound card init */
-static int snd_rpi_raspidac3_init(struct snd_soc_pcm_runtime *rtd)
-{
- int ret;
- struct snd_soc_card *card = rtd->card;
- struct snd_soc_codec *codec = rtd->codec;
- snd_soc_update_bits(codec, PCM512x_GPIO_EN, 0x08, 0x08);
- snd_soc_update_bits(codec, PCM512x_GPIO_OUTPUT_4, 0xf, 0x02);
- snd_soc_update_bits(codec, PCM512x_GPIO_CONTROL_1, 0x08,0x00);
-
- ret = snd_soc_limit_volume(card, "Digital Playback Volume", 207);
- if (ret < 0)
- dev_warn(card->dev, "Failed to set volume limit: %d\n", ret);
- else {
- struct snd_kcontrol *kctl;
-
- ret = snd_soc_limit_volume(card,
- "TPA6130A2 Headphone Playback Volume",
- 54);
- if (ret < 0)
- dev_warn(card->dev, "Failed to set TPA6130A2 volume limit: %d\n",
- ret);
- kctl = snd_soc_card_get_kcontrol(card,
- "TPA6130A2 Headphone Playback Volume");
- if (kctl) {
- strcpy(kctl->id.name, "Headphones Playback Volume");
- /* disable the volume dB scale so alsamixer works */
- kctl->vd[0].access = SNDRV_CTL_ELEM_ACCESS_READWRITE;
- }
-
- kctl = snd_soc_card_get_kcontrol(card,
- "TPA6130A2 Headphone Playback Switch");
- if (kctl)
- strcpy(kctl->id.name, "Headphones Playback Switch");
- }
-
- return 0;
-}
-
-/* startup */
-static int snd_rpi_raspidac3_startup(struct snd_pcm_substream *substream) {
- struct snd_soc_pcm_runtime *rtd = substream->private_data;
- struct snd_soc_codec *codec = rtd->codec;
- snd_soc_update_bits(codec, PCM512x_GPIO_CONTROL_1, 0x08,0x08);
- return 0;
-}
-
-/* shutdown */
-static void snd_rpi_raspidac3_shutdown(struct snd_pcm_substream *substream) {
- struct snd_soc_pcm_runtime *rtd = substream->private_data;
- struct snd_soc_codec *codec = rtd->codec;
- snd_soc_update_bits(codec, PCM512x_GPIO_CONTROL_1, 0x08,0x00);
-}
-
-/* machine stream operations */
-static struct snd_soc_ops snd_rpi_raspidac3_ops = {
- .startup = snd_rpi_raspidac3_startup,
- .shutdown = snd_rpi_raspidac3_shutdown,
-};
-
-/* interface setup */
-static struct snd_soc_dai_link snd_rpi_raspidac3_dai[] = {
-{
- .name = "RaspiDAC Rev.3x",
- .stream_name = "RaspiDAC HiFi",
- .cpu_dai_name = "bcm2708-i2s.0",
- .codec_dai_name = "pcm512x-hifi",
- .platform_name = "bcm2708-i2s.0",
- .codec_name = "pcm512x.1-004c",
- .dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
- SND_SOC_DAIFMT_CBS_CFS,
- .ops = &snd_rpi_raspidac3_ops,
- .init = snd_rpi_raspidac3_init,
-},
-};
-
-/* audio machine driver */
-static struct snd_soc_card snd_rpi_raspidac3 = {
- .name = "RaspiDAC Rev.3x HiFi Audio Card",
- .owner = THIS_MODULE,
- .dai_link = snd_rpi_raspidac3_dai,
- .num_links = ARRAY_SIZE(snd_rpi_raspidac3_dai),
-};
-
-/* sound card test */
-static int snd_rpi_raspidac3_probe(struct platform_device *pdev)
-{
- int ret = 0;
-
- snd_rpi_raspidac3.dev = &pdev->dev;
-
- if (pdev->dev.of_node) {
- struct device_node *i2s_node;
- struct snd_soc_dai_link *dai = &snd_rpi_raspidac3_dai[0];
- i2s_node = of_parse_phandle(pdev->dev.of_node,
- "i2s-controller", 0);
-
- if (i2s_node) {
- dai->cpu_dai_name = NULL;
- dai->cpu_of_node = i2s_node;
- dai->platform_name = NULL;
- dai->platform_of_node = i2s_node;
- }
- }
-
- ret = snd_soc_register_card(&snd_rpi_raspidac3);
- if (ret && ret != -EPROBE_DEFER)
- dev_err(&pdev->dev,
- "snd_soc_register_card() failed: %d\n", ret);
-
- return ret;
-}
-
-/* sound card disconnect */
-static int snd_rpi_raspidac3_remove(struct platform_device *pdev)
-{
- return snd_soc_unregister_card(&snd_rpi_raspidac3);
-}
-
-static const struct of_device_id raspidac3_of_match[] = {
- { .compatible = "jg,raspidacv3", },
- {},
-};
-MODULE_DEVICE_TABLE(of, raspidac3_of_match);
-
-/* sound card platform driver */
-static struct platform_driver snd_rpi_raspidac3_driver = {
- .driver = {
- .name = "snd-rpi-raspidac3",
- .owner = THIS_MODULE,
- .of_match_table = raspidac3_of_match,
- },
- .probe = snd_rpi_raspidac3_probe,
- .remove = snd_rpi_raspidac3_remove,
-};
-
-module_platform_driver(snd_rpi_raspidac3_driver);
-
-MODULE_AUTHOR("Jan Grulich <jan@grulich.eu>");
-MODULE_DESCRIPTION("ASoC Driver for RaspiDAC Rev.3x");
-MODULE_LICENSE("GPL v2");