You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/mac80211/patches/000-disable_drivers.patch

38 lines
1.2 KiB
Diff

--- a/config.mk
+++ b/config.mk
@@ -724,34 +724,3 @@ endif #CONFIG_LEDS_TRIGGERS
# export CONFIG_RFKILL_BACKPORT_INPUT=y
endif #CONFIG_COMPAT_KERNEL_2_6_31
-# compilation has been tested down to 3.0 but run time
-# tests have only started on 3.2.
-ifndef CONFIG_COMPAT_KERNEL_3_2
-# Basic DRM support
-export CONFIG_COMPAT_VIDEO_MODULES=y
-export CONFIG_COMPAT_DRM=m
-export CONFIG_COMPAT_DRM_TTM=m
-export CONFIG_COMPAT_DRM_KMS_HELPER=m
-export CONFIG_COMPAT_DRM_LOAD_EDID_FIRMWARE=y
-# Intel i915
-export CONFIG_COMPAT_DRM_I915=m
-# ATI/AMD Radeon
-export CONFIG_COMPAT_DRM_RADEON=m
-export CONFIG_COMPAT_DRM_RADEON_KMS=y
-export CONFIG_COMPAT_DRM_NOUVEAU=m
-export CONFIG_COMPAT_DRM_NOUVEAU_BACKLIGHT=y
-export CONFIG_COMPAT_NOUVEAU_DEBUG=5
-export CONFIG_COMPAT_NOUVEAU_DEBUG_DEFAULT=3
-ifdef CONFIG_MEDIA_CONTROLLER
-export CONFIG_COMPAT_USB_VIDEO_CLASS=m
-endif #CONFIG_MEDIA_CONTROLLER
-export CONFIG_USB_VIDEO_CLASS=y
-endif #CONFIG_COMPAT_KERNEL_3_2
-
-ifndef CONFIG_COMPAT_KERNEL_3_2
-export CONFIG_COMPAT_MEDIA_MODULES=y
-export CONFIG_COMPAT_VIDEO_V4L2=m
-export CONFIG_COMPAT_VIDEOBUF2_CORE=m
-export CONFIG_COMPAT_VIDEOBUF2_VMALLOC=m
-export CONFIG_COMPAT_VIDEOBUF2_MEMOPS=m
-endif #CONFIG_COMPAT_KERNEL_3_2