You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/atheros/patches-2.6.23/110-spiflash.patch

25 lines
994 B
Diff

Index: linux-2.6.23.17/drivers/mtd/devices/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/mtd/devices/Kconfig
+++ linux-2.6.23.17/drivers/mtd/devices/Kconfig
@@ -76,6 +76,10 @@ config MTD_M25P80
used for program and data storage. Set up your spi devices
with the right board-specific platform data.
+config MTD_SPIFLASH
+ tristate "Atheros AR2315/6/7 SPI Flash support"
+ depends on ATHEROS_AR5315
+
config MTD_SLRAM
tristate "Uncached system RAM"
help
Index: linux-2.6.23.17/drivers/mtd/devices/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/mtd/devices/Makefile
+++ linux-2.6.23.17/drivers/mtd/devices/Makefile
@@ -18,3 +18,4 @@ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
obj-$(CONFIG_MTD_M25P80) += m25p80.o
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o