You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/tools/quilt/patches/100-patch_2.6.1_version.patch

16 lines
400 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -274,7 +274,11 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
+ if test x$1 = xGNU ; then
+ patch_version=$3
+ else
+ patch_version=$2
+ fi
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version