You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/at91/patches/800-netus-support.patch

69 lines
2.1 KiB
Diff

--- a/arch/arm/mach-at91/Kconfig
+++ b/arch/arm/mach-at91/Kconfig
@@ -354,6 +354,13 @@ config MACH_CPU9G20
Select this if you are using a Eukrea Electromatique's
CPU9G20 Board <http://www.eukrea.com/>
+config MACH_NETUS_FOXBOARD
+ bool "Acmesystems NetusG20 board"
+ depends on ARCH_AT91SAM9G20
+ help
+ Select this if you are using a Acmesystems NetusG20
+ board <http://netus.acmesystems.it/>
+
endif
# ----------------------------------------------------------
@@ -444,6 +451,40 @@
On AT91SAM926x boards both types of NAND flash can be present
(8 and 16 bit data bus width).
+config NETUS_HEARTBEAT_LED
+ bool "Use heartbeat trigger for led"
+ depends on MACH_NETUS_FOXBOARD
+ select LEDS_TRIGGER_HEARTBEAT
+ help
+ Select this option to enable default trigger heartbeart for
+ FoxBoardG20 user led.
+
+config NETUS_SERIALS
+ bool "Enable serials"
+ depends on MACH_NETUS_FOXBOARD
+ help
+ Select this option to enable serials interface /dev/ttyS1,
+ /dev/ttyS2 and /dev/ttyS5 (for oLed interface)
+
+config NETUS_USE_DATAFLASH
+ bool "Enable the dataflash"
+ select MTD_DATAFLASH
+ select MTD_PARTITIONS
+ select MTD_CMDLINE_PARTS
+ select MTD_CHAR
+ select MTD_BLOCK
+ depends on MACH_NETUS_FOXBOARD
+ help
+ Select this option to use the dataflash.
+
+config NETUS_FOXGM
+ bool "Enable support for FoxGM board"
+ depends on MACH_NETUS_FOXBOARD
+ select LEDS_TRIGGER_HEARTBEAT
+ help
+ Select this option to auto-configure leds and
+ serial ports according to FOXGM board.
+
# ----------------------------------------------------------
comment "AT91 Feature Selections"
--- linux-2.6.35.4.orig/arch/arm/mach-at91/Makefile 2010-09-18 13:29:33.000000000 +0200
+++ linux-2.6.35.4/arch/arm/mach-at91/Makefile 2010-09-18 13:31:31.000000000 +0200
@@ -65,6 +65,7 @@
obj-$(CONFIG_MACH_CPU9G20) += board-cpu9krea.o
obj-$(CONFIG_MACH_STAMP9G20) += board-stamp9g20.o
obj-$(CONFIG_MACH_PORTUXG20) += board-stamp9g20.o
+obj-$(CONFIG_MACH_NETUS_FOXBOARD) += board-netus-foxboard.o
# AT91SAM9G45 board-specific support
obj-$(CONFIG_MACH_AT91SAM9G45EKES) += board-sam9m10g45ek.o