You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/atheros/patches-2.6.23/130-ar2313_ethernet.patch

30 lines
1.1 KiB
Diff

Index: linux-2.6.23.17/drivers/net/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/net/Kconfig
+++ linux-2.6.23.17/drivers/net/Kconfig
@@ -348,6 +348,12 @@ config AX88796
AX88796 driver, using platform bus to provide
chip detection and resources
+config AR2313
+ tristate "AR2313 Ethernet support"
+ depends on NET_ETHERNET && ATHEROS
+ help
+ Support for the AR231x/531x ethernet controller
+
config MACE
tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32
Index: linux-2.6.23.17/drivers/net/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/net/Makefile
+++ linux-2.6.23.17/drivers/net/Makefile
@@ -182,6 +182,7 @@ obj-$(CONFIG_EQUALIZER) += eql.o
obj-$(CONFIG_LGUEST_NET) += lguest_net.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
+obj-$(CONFIG_AR2313) += ar2313/
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
obj-$(CONFIG_DECLANCE) += declance.o