You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/brcm63xx/patches-2.6.30/006-pcmcia_cardbus_support....

44 lines
1.7 KiB
Diff

From b17597be763621ba63534fda6e1ea0a802be2087 Mon Sep 17 00:00:00 2001
From: Maxime Bizon <mbizon@freebox.fr>
Date: Fri, 18 Jul 2008 21:18:51 +0200
Subject: [PATCH] [MIPS] BCM63XX: Add PCMCIA & Cardbus support.
Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
---
arch/mips/bcm63xx/Makefile | 1 +
arch/mips/bcm63xx/dev-pcmcia.c | 135 +++++
drivers/pcmcia/Kconfig | 4 +
drivers/pcmcia/Makefile | 1 +
drivers/pcmcia/bcm63xx_pcmcia.c | 521 ++++++++++++++++++++
drivers/pcmcia/bcm63xx_pcmcia.h | 65 +++
include/asm-mips/mach-bcm63xx/bcm63xx_dev_pcmcia.h | 13 +
7 files changed, 740 insertions(+), 0 deletions(-)
create mode 100644 arch/mips/bcm63xx/dev-pcmcia.c
create mode 100644 drivers/pcmcia/bcm63xx_pcmcia.c
create mode 100644 drivers/pcmcia/bcm63xx_pcmcia.h
create mode 100644 include/asm-mips/mach-bcm63xx/bcm63xx_dev_pcmcia.h
--- a/drivers/pcmcia/Kconfig
+++ b/drivers/pcmcia/Kconfig
@@ -192,6 +192,10 @@ config PCMCIA_AU1X00
tristate "Au1x00 pcmcia support"
depends on SOC_AU1X00 && PCMCIA
+config PCMCIA_BCM63XX
+ tristate "bcm63xx pcmcia support"
+ depends on BCM63XX && PCMCIA
+
config PCMCIA_SA1100
tristate "SA1100 support"
depends on ARM && ARCH_SA1100 && PCMCIA
--- a/drivers/pcmcia/Makefile
+++ b/drivers/pcmcia/Makefile
@@ -27,6 +27,7 @@ obj-$(CONFIG_PCMCIA_SA1111) += sa11xx_
obj-$(CONFIG_M32R_PCC) += m32r_pcc.o
obj-$(CONFIG_M32R_CFC) += m32r_cfc.o
obj-$(CONFIG_PCMCIA_AU1X00) += au1x00_ss.o
+obj-$(CONFIG_PCMCIA_BCM63XX) += bcm63xx_pcmcia.o
obj-$(CONFIG_PCMCIA_VRC4171) += vrc4171_card.o
obj-$(CONFIG_PCMCIA_VRC4173) += vrc4173_cardu.o
obj-$(CONFIG_OMAP_CF) += omap_cf.o