You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/bcm27xx/patches-4.19/950-0256-arm64-dts-broadcom...

24 lines
718 B
Diff

From bb8f38337d08dc1ac78ab251aa0b515eea45a79e Mon Sep 17 00:00:00 2001
From: Phil Elwell <phil@raspberrypi.org>
Date: Tue, 15 Jan 2019 09:56:41 +0000
Subject: [PATCH] arm64: dts: broadcom: Enable fixups for overlays
See: https://github.com/raspberrypi/linux/pull/2733
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
---
arch/arm64/boot/dts/broadcom/Makefile | 5 +++++
1 file changed, 5 insertions(+)
--- a/arch/arm64/boot/dts/broadcom/Makefile
+++ b/arch/arm64/boot/dts/broadcom/Makefile
@@ -9,3 +9,8 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rp
subdir-y += northstar2
subdir-y += stingray
+
+# Enable fixups to support overlays on BCM2835 platforms
+ifeq ($(CONFIG_ARCH_BCM2835),y)
+ DTC_FLAGS ?= -@
+endif