You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch

32 lines
1.0 KiB
Diff

Index: linux-2.6.23.17/drivers/net/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/net/Kconfig
+++ linux-2.6.23.17/drivers/net/Kconfig
@@ -348,6 +348,13 @@ config AX88796
AX88796 driver, using platform bus to provide
chip detection and resources
+config KORINA
+ tristate "Korina Local Ethernet support"
+ depends on NET_ETHERNET && ( IDT_EB434 || MIKROTIK_RB500)
+ help
+ IDT RC32434 has one local ethernet port. Say Y here to enable it.
+ To compile this driver as a module, choose M here.
+
config MACE
tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32
Index: linux-2.6.23.17/drivers/net/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/net/Makefile
+++ linux-2.6.23.17/drivers/net/Makefile
@@ -25,6 +25,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
#
obj-$(CONFIG_PLIP) += plip.o
+obj-$(CONFIG_KORINA) += korina.o
+
obj-$(CONFIG_ROADRUNNER) += rrunner.o
obj-$(CONFIG_HAPPYMEAL) += sunhme.o