You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/brcm2708/patches-4.14/950-0165-Added-support-for-...

106 lines
2.5 KiB
Diff

From 921c7f42c3ed6cebea4edff86bbe2b6c1b882d53 Mon Sep 17 00:00:00 2001
From: Yevhen Kyriukha <kirgene@gmail.com>
Date: Sun, 14 Jan 2018 13:36:24 +0200
Subject: [PATCH 165/454] Added support for mbed AudioCODEC (TLV320AIC23B)
Signed-off-by: Yevhen Kyriukha <kirgene@gmail.com>
---
arch/arm/boot/dts/overlays/Makefile | 1 +
arch/arm/boot/dts/overlays/README | 6 ++
.../boot/dts/overlays/mbed-dac-overlay.dts | 64 +++++++++++++++++++
3 files changed, 71 insertions(+)
create mode 100644 arch/arm/boot/dts/overlays/mbed-dac-overlay.dts
--- a/arch/arm/boot/dts/overlays/Makefile
+++ b/arch/arm/boot/dts/overlays/Makefile
@@ -58,6 +58,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
justboom-dac.dtbo \
justboom-digi.dtbo \
lirc-rpi.dtbo \
+ mbed-dac.dtbo \
mcp23017.dtbo \
mcp23s17.dtbo \
mcp2515-can0.dtbo \
--- a/arch/arm/boot/dts/overlays/README
+++ b/arch/arm/boot/dts/overlays/README
@@ -965,6 +965,12 @@ Params: gpio_out_pin GPIO for
(default "off")
+Name: mbed-dac
+Info: Configures the mbed AudioCODEC (TLV320AIC23B)
+Load: dtoverlay=mbed-dac
+Params: <None>
+
+
Name: mcp23017
Info: Configures the MCP23017 I2C GPIO expander
Load: dtoverlay=mcp23017,<param>=<val>
--- /dev/null
+++ b/arch/arm/boot/dts/overlays/mbed-dac-overlay.dts
@@ -0,0 +1,64 @@
+// Definitions for mbed DAC
+/dts-v1/;
+/plugin/;
+
+/ {
+ compatible = "brcm,bcm2708";
+
+ fragment@0 {
+ target = <&i2s>;
+ __overlay__ {
+ status = "okay";
+ };
+ };
+
+ fragment@1 {
+ target = <&i2c1>;
+ __overlay__ {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ tlv320aic23: codec@1a {
+ #sound-dai-cells = <0>;
+ reg = <0x1a>;
+ compatible = "ti,tlv320aic23";
+ status = "okay";
+ };
+ };
+ };
+
+ fragment@2 {
+ target = <&sound>;
+ __overlay__ {
+ compatible = "simple-audio-card";
+ i2s-controller = <&i2s>;
+ status = "okay";
+
+ simple-audio-card,name = "mbed-DAC";
+
+ simple-audio-card,widgets =
+ "Microphone", "Mic Jack",
+ "Line", "Line In",
+ "Headphone", "Headphone Jack";
+
+ simple-audio-card,routing =
+ "Headphone Jack", "LHPOUT",
+ "Headphone Jack", "RHPOUT",
+ "LLINEIN", "Line In",
+ "RLINEIN", "Line In",
+ "MICIN", "Mic Jack";
+
+ simple-audio-card,format = "i2s";
+
+ simple-audio-card,cpu {
+ sound-dai = <&i2s>;
+ };
+
+ sound_master: simple-audio-card,codec {
+ sound-dai = <&tlv320aic23>;
+ system-clock-frequency = <12288000>;
+ };
+ };
+ };
+};