You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/at91/patches-2.6.25/007-mtd-partition.patch

37 lines
1.1 KiB
Diff

--- a/drivers/mtd/devices/at91_dataflash.c
+++ b/drivers/mtd/devices/at91_dataflash.c
@@ -175,7 +175,7 @@ static struct mtd_partition static_parti
};
#endif
-static const char *part_probes[] = { "cmdlinepart", NULL, };
+static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
#endif
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -168,6 +168,12 @@ config MTD_OF_PARTS
the partition map from the children of the flash node,
as described in Documentation/powerpc/booting-without-of.txt.
+config MTD_AT91_PARTS
+ tristate "Atmel AT91 partitioning support"
+ depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
+ ---help---
+ Atmel AT91 partitioning support
+
comment "User Modules And Translation Layers"
config MTD_CHAR
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+obj-$(CONFIG_MTD_AT91_PARTS) += at91part.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o