You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/target/linux/ar7/patches-2.6.24/110-flash.patch

44 lines
1.7 KiB
Diff

Index: linux-2.6.24.7/drivers/mtd/Kconfig
===================================================================
--- linux-2.6.24.7.orig/drivers/mtd/Kconfig
+++ linux-2.6.24.7/drivers/mtd/Kconfig
@@ -160,6 +160,12 @@ config MTD_AFS_PARTS
for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
+config MTD_AR7_PARTS
+ tristate "TI AR7 partitioning support"
+ depends on MTD_PARTITIONS
+ ---help---
+ TI AR7 partitioning support
+
comment "User Modules And Translation Layers"
config MTD_CHAR
Index: linux-2.6.24.7/drivers/mtd/Makefile
===================================================================
--- linux-2.6.24.7.orig/drivers/mtd/Makefile
+++ linux-2.6.24.7/drivers/mtd/Makefile
@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
Index: linux-2.6.24.7/drivers/mtd/maps/physmap.c
===================================================================
--- linux-2.6.24.7.orig/drivers/mtd/maps/physmap.c
+++ linux-2.6.24.7/drivers/mtd/maps/physmap.c
@@ -74,7 +74,8 @@ static int physmap_flash_remove(struct p
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
+ "ar7part", NULL };
#endif
static int physmap_flash_probe(struct platform_device *dev)