You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/strongswan/patches/100-ar-fixes.patch

82 lines
2.9 KiB
Diff

Index: strongswan-2.8.2/lib/libcrypto/libaes/Makefile
===================================================================
--- strongswan-2.8.2.orig/lib/libcrypto/libaes/Makefile 2007-06-04 13:23:04.777007680 +0200
+++ strongswan-2.8.2/lib/libcrypto/libaes/Makefile 2007-06-04 13:23:04.873992936 +0200
@@ -25,10 +25,8 @@
$(BLIB): $(LIBOBJ)
/bin/rm -f $(BLIB)
- ar cr $(BLIB) $(LIBOBJ)
- -if test -s /bin/ranlib; then /bin/ranlib $(BLIB); \
- else if test -s /usr/bin/ranlib; then /usr/bin/ranlib $(BLIB); \
- else exit 0; fi; fi
+ $(AR) cr $(BLIB) $(LIBOBJ)
+ $(RANLIB) $(BLIB)
testx: test_main_mac.o $(BLIB)
$(CC) -o $@ $^
Index: strongswan-2.8.2/lib/libcrypto/libblowfish/Makefile
===================================================================
--- strongswan-2.8.2.orig/lib/libcrypto/libblowfish/Makefile 2007-06-04 13:23:04.783006768 +0200
+++ strongswan-2.8.2/lib/libcrypto/libblowfish/Makefile 2007-06-04 13:23:04.873992936 +0200
@@ -58,7 +58,7 @@
lib: $(LIB)
$(LIB): $(LIBOBJ)
- $(AR) $(LIB) $(LIBOBJ)
+ $(AR) -r $(LIB) $(LIBOBJ)
$(RANLIB) $(LIB)
# elf
Index: strongswan-2.8.2/lib/libcrypto/libserpent/Makefile
===================================================================
--- strongswan-2.8.2.orig/lib/libcrypto/libserpent/Makefile 2007-06-04 13:23:04.790005704 +0200
+++ strongswan-2.8.2/lib/libcrypto/libserpent/Makefile 2007-06-04 13:23:04.873992936 +0200
@@ -8,10 +8,8 @@
$(BLIB): $(LIBOBJ)
/bin/rm -f $(BLIB)
- ar cr $(BLIB) $(LIBOBJ)
- -if test -s /bin/ranlib; then /bin/ranlib $(BLIB); \
- else if test -s /usr/bin/ranlib; then /usr/bin/ranlib $(BLIB); \
- else exit 0; fi; fi
+ $(AR) cr $(BLIB) $(LIBOBJ)
+ $(RANLIB) $(BLIB)
test: test_main.o $(BLIB)
$(CC) -o $@ $^
Index: strongswan-2.8.2/lib/libcrypto/libsha2/Makefile
===================================================================
--- strongswan-2.8.2.orig/lib/libcrypto/libsha2/Makefile 2007-06-04 13:23:04.796004792 +0200
+++ strongswan-2.8.2/lib/libcrypto/libsha2/Makefile 2007-06-04 13:23:04.874992784 +0200
@@ -9,10 +9,8 @@
$(BLIB): $(LIBOBJ)
/bin/rm -f $(BLIB)
- ar cr $(BLIB) $(LIBOBJ)
- -if test -s /bin/ranlib; then /bin/ranlib $(BLIB); \
- else if test -s /usr/bin/ranlib; then /usr/bin/ranlib $(BLIB); \
- else exit 0; fi; fi
+ $(AR) cr $(BLIB) $(LIBOBJ)
+ $(RANLIB) $(BLIB)
test: test_main.o $(BLIB)
$(CC) -o $@ $^
Index: strongswan-2.8.2/lib/libcrypto/libtwofish/Makefile
===================================================================
--- strongswan-2.8.2.orig/lib/libcrypto/libtwofish/Makefile 2007-06-04 13:23:04.804003576 +0200
+++ strongswan-2.8.2/lib/libcrypto/libtwofish/Makefile 2007-06-04 13:23:04.874992784 +0200
@@ -9,10 +9,8 @@
$(BLIB): $(LIBOBJ)
/bin/rm -f $(BLIB)
- ar cr $(BLIB) $(LIBOBJ)
- -if test -s /bin/ranlib; then /bin/ranlib $(BLIB); \
- else if test -s /usr/bin/ranlib; then /usr/bin/ranlib $(BLIB); \
- else exit 0; fi; fi
+ $(AR) cr $(BLIB) $(LIBOBJ)
+ $(RANLIB) $(BLIB)
test: test_main.o $(BLIB)
$(CC) -o $@ $^