You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/fuse/patches/112-no_break_on_mknod.patch

14 lines
615 B
Diff

Index: fuse-2.6.5/util/Makefile.in
===================================================================
--- fuse-2.6.5.orig/util/Makefile.in 2007-06-23 13:03:50.000000000 +0200
+++ fuse-2.6.5/util/Makefile.in 2007-06-23 13:03:50.000000000 +0200
@@ -489,7 +489,7 @@
install-exec-hook:
-chown root $(DESTDIR)$(bindir)/fusermount
-chmod u+s $(DESTDIR)$(bindir)/fusermount
- @if test ! -e $(DESTDIR)/dev/fuse; then \
+ -@if test ! -e $(DESTDIR)/dev/fuse; then \
$(mkdir_p) $(DESTDIR)/dev; \
echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true"; \
mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true; \