You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
openwrt/package/boot/uboot-sunxi/patches/213-Revert-sunxi-Use-binman...

59 lines
1.8 KiB
Diff

From cf1defd80b7594f6f2721ab2dacffe48522abfca Mon Sep 17 00:00:00 2001
From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Thu, 20 Jul 2017 19:51:01 +0200
Subject: [PATCH 213/213] Revert "sunxi: Use binman for sunxi boards"
This reverts commit 61b994a386eb6f631dc1c2194d4cce9b1a43542c.
---
Makefile | 6 ++++--
arch/arm/dts/sunxi-u-boot.dtsi | 14 --------------
scripts/Makefile.lib | 4 ++--
3 files changed, 6 insertions(+), 18 deletions(-)
delete mode 100644 arch/arm/dts/sunxi-u-boot.dtsi
--- a/Makefile
+++ b/Makefile
@@ -1125,8 +1125,10 @@ u-boot-x86-16bit.bin: u-boot FORCE
endif
ifneq ($(CONFIG_ARCH_SUNXI),)
-u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb FORCE
- $(call if_changed,binman)
+OBJCOPYFLAGS_u-boot-sunxi-with-spl.bin = -I binary -O binary \
+ --pad-to=$(CONFIG_SPL_PAD_TO) --gap-fill=0xff
+u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img FORCE
+ $(call if_changed,pad_cat)
endif
ifneq ($(CONFIG_TEGRA),)
--- a/arch/arm/dts/sunxi-u-boot.dtsi
+++ /dev/null
@@ -1,14 +0,0 @@
-#include <config.h>
-
-/ {
- binman {
- filename = "u-boot-sunxi-with-spl.bin";
- pad-byte = <0xff>;
- blob {
- filename = "spl/sunxi-spl.bin";
- };
- u-boot-img {
- pos = <CONFIG_SPL_PAD_TO>;
- };
- };
-};
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
@@ -308,8 +308,8 @@ quiet_cmd_dtc = DTC $@
# Modified for U-Boot
# Bring in any U-Boot-specific include after the '/dts-v1/;' header
cmd_dtc = mkdir -p $(dir ${dtc-tmp}) ; \
- cat $< $(if $(u_boot_dtsi),\
- | sed 's%^/ {$$%\#include \"$(u_boot_dtsi)\"\n&%') | \
+ cat $< $(if $(u-boot-dtsi),\
+ | sed 's%^/ {$$%\#include \"$(u-boot-dtsi)\"\n&%') | \
$(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) - ; \
$(DTC) -O dtb -o $@ -b 0 \
-i $(dir $<) $(DTC_FLAGS) \